I have a Western Digital MyBook (25EE) 8TB External Drive. It is formatted with exFAT. I can't recall exactly how it was formatted, but I believe it was done with Synology's DiskStation for my Synology NAS. I am able to mount and read the drive when I connect it to the NAS, but not on macOS Sierra 10.12.6.

The drive shows up in Disk Utility, but mounting does nothing. I have run "First Aid" with no errors.

enter image description here enter image description here

Disk Utility incorrectly thinks that the usage is 8/8 TB. As can be in a screenshot below, usage is around 4.2/8 TB. The drive mainly contains a Synology HyperBackup file (.hbk) which makes up almost single-handedly all of those 4.2 TB.

According to Synology DiskStation, the main partition is exFAT and I think the EFI partition is vfat:

enter image description here

The drive also shows up in diskutil as disk2s2 but I can't mount it:

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *8.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data WD My Book              8.0 TB     disk2s2

$ mount disk2s2
mount: disk2s2: unknown special file or file system.

$ diskutil mountDisk disk2
One or more volume(s) failed to mount

NB: (I tried following these instructions for FUSE for macOS, but I suppose they're not really relevant since exFAT should be supported natively in macOS these days.)

I don't have the faintest idea where to start on this issue – what could be the problem here?

Edit 1: Block Sizes


$ diskutil info disk2 | grep "Block Size"
   Device Block Size:        512 Bytes

$ diskutil info disk2s1 | grep "Block Size"
   Device Block Size:        512 Bytes

$ diskutil info disk2s2 | grep "Block Size"
   Device Block Size:        512 Bytes

Synology SSH:

Used fdisk -l. Notice the GPT PMBR size mismatch – maybe it has some relevance?

GPT PMBR size mismatch (4294967294 != 2743150591) will be corrected by w(rite).
Disk /dev/sdq: 7.3 TiB, 8001562869760 bytes, 15628052480 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt

Device      Start         End     Sectors  Size Type
/dev/sdq1      40      409639      409600  200M EFI System
/dev/sdq2  411648 15628050431 15627638784  7.3T Microsoft basic data

Edit 2: GPT

$ sudo gpt -r show disk2

        start         size  index  contents
            0            1         PMBR
            1            1         Pri GPT header
            2           32         Pri GPT table
           34            6         
           40       409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93E####
       409640         2008         
       411648  15627638784      2  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B726####
  15628050432         2015         
  15628052447           32         Sec GPT table
  15628052479            1         Sec GPT header

Edit 3: Mounting EFI

Apparently macOS is able to mount and Finder list the contents of the EFI.

$ diskutil mountDisk disk2
One or more volume(s) failed to mount

enter image description here

The volume that fails to mount is the primary exFAT volume. macOS requires the EFI volume to be unmounted or it will complain about not properly ejecting disks.

  • 2
  • @klanomath Sorry for the delayed response – I tried nulling the fsck per your instructions but it didn't seem to do anything, mounting the disk failed as before, so I removed the line from fstab again. – P A N Jul 30 '17 at 13:31
  • Are the permissions of the drive correct? – little tiny man Aug 3 '17 at 18:37
  • @littletinyman How can I check permissions of the drive? Thanks! – P A N Aug 8 '17 at 10:03
  • @winterflags I'm having this issue. Did you resolve it meaningfully? – Stephen Ellis Nov 24 '17 at 19:21

If your ExFAT drive is not mounting, here is the solution.

sudo pkill -f fsck

fsck was holding the disk hostage. A quick ps aux | grep fsck revealed that indeed it was hijacking the disk/volume as soon as it was plugged in. sudo pkill -f fsck (or just kill with the PID if you prefer) immediately allowed the volume to be mounted.

Then to make the hard drive writable, you have to run the Disk Utility "S.O.S.", unmount then mount it again.

  • 1
    This worked for me, +1 – bafromca May 18 '20 at 4:28
  • didn't work for me – wesley franks May 20 '20 at 16:06
  • Disk Utility "S.O.S." is just running fsck, isn't it? So, maybe the solution is just to wait and let fsck continue to completion? – meelash Dec 16 '20 at 23:33
  • You are my hero!!! I was almost to return my WD Passport drive back to the store...lol – user1098761 Feb 23 at 0:41

Formatting large volumes exFAT on Windows tends to default to an allocation unit size (read block size) of larger than 1024. macOS has trouble finding the boot region on disks like this. Backup your external drive, reformat it on windows with a block size of 1024, then copy everything back.

  • 2
    I can confirm that after I re-formated my external 2 TB HDD from exFAT with 2048K allocation unit size to exFAT with 1024K allocation unit size, the disk is now discoverable by Mac OS and I can work with it just fine. – retif Jul 14 '19 at 14:22

The recent Western Digital "easy store" and "My Book" hard drives have a Mac Sierra 10.12.6 issue: They are invisible to the Desktop.

WD Utilities says my two drives check out ok; Mac Utilities recognizes both hard drives.

Going to the Mac Genius Bar on Monday. BestBuy sold me the original WD easystore 8T and WD sent me a My Book 8T. BestBuy said the WD easystore was dying; a computer technician said no way. Both WD HD's were reformatted ExFat. MacBook Pro Finder cannot see either hard drive.

  • 1
    Good point - some drives do “bizarre things” at the controller level to “protect” data or “enhance” the experience and all most Apple users will want to do is have an easy button to permanently disable those “features” or an easy way to not spend money on them in the first place. – bmike Nov 10 '17 at 20:55

exFAT (Extended File Allocation Table) file system is the successor to the great old FAT32 file system. It has many pros and cons. One of the pros, for instance, is file size limit's now up to 16 Exabytes. But...

It's not used and was not designed for formatting hard drives. It is only recommended for flash memory storage. That's the only reason it is currently not considered as huge competitor to NTFS on hard drives. Also exFAT contributes to the emergence of permission problems and corrupted files. Suppose your situation is related to this issue.

I would try to reformat it although you've got 8TB to transfer.


I faced this issue in the latest macOs Big Sur 11.2.1. The disk won't mount or soft eject. I ran Frist Aid option in Disk Utility which took a few minutes since it was scanning the Trancend external drive. After the scan, I had to unmount and mount it back again inorder for the disk to be writable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .