I have a Western Digital MyBook (25EE) 8TB External Drive. It is formatted with exFAT. I can't recall exactly how it was formatted, but I believe it was done with Synology's DiskStation for my Synology NAS. I am able to mount and read the drive when I connect it to the NAS, but not on macOS Sierra 10.12.6.

The drive shows up in Disk Utility, but mounting does nothing. I have run "First Aid" with no errors.

enter image description here enter image description here

Disk Utility incorrectly thinks that the usage is 8/8 TB. As can be seen in the screenshot below, usage is around 4.2/8 TB. The drive mainly contains a Synology HyperBackup file (.hbk) which makes up almost single-handedly all of those 4.2 TB.

According to Synology DiskStation, the main partition is exFAT and I think the EFI partition is vfat:

enter image description here

The drive also shows up in diskutil as disk2s2 but I can't mount it:

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *8.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data WD My Book              8.0 TB     disk2s2

$ mount disk2s2
mount: disk2s2: unknown special file or file system.

$ diskutil mountDisk disk2
One or more volume(s) failed to mount

NB: (I tried following these instructions for FUSE for macOS, but I suppose they're not really relevant since exFAT should be supported natively in macOS these days.)

I don't have the faintest idea where to start on this issue – what could be the problem here?

Edit 1: Block Sizes


$ diskutil info disk2 | grep "Block Size"
   Device Block Size:        512 Bytes

$ diskutil info disk2s1 | grep "Block Size"
   Device Block Size:        512 Bytes

$ diskutil info disk2s2 | grep "Block Size"
   Device Block Size:        512 Bytes

Synology SSH:

Used fdisk -l. Notice the GPT PMBR size mismatch – maybe it has some relevance?

GPT PMBR size mismatch (4294967294 != 2743150591) will be corrected by w(rite).
Disk /dev/sdq: 7.3 TiB, 8001562869760 bytes, 15628052480 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt

Device      Start         End     Sectors  Size Type
/dev/sdq1      40      409639      409600  200M EFI System
/dev/sdq2  411648 15628050431 15627638784  7.3T Microsoft basic data

Edit 2: GPT

$ sudo gpt -r show disk2

        start         size  index  contents
            0            1         PMBR
            1            1         Pri GPT header
            2           32         Pri GPT table
           34            6         
           40       409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93E####
       409640         2008         
       411648  15627638784      2  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B726####
  15628050432         2015         
  15628052447           32         Sec GPT table
  15628052479            1         Sec GPT header

Edit 3: Mounting EFI

Apparently macOS is able to mount and Finder list the contents of the EFI.

$ diskutil mountDisk disk2
One or more volume(s) failed to mount

enter image description here

The volume that fails to mount is the primary exFAT volume. macOS requires the EFI volume to be unmounted or it will complain about not properly ejecting disks.

  • 2
    Hmmm; Disable the disk check when reconnecting an improperly disconnected disk to OS X may help - last-ditch
    – klanomath
    Commented Jul 29, 2017 at 14:20
  • @klanomath Sorry for the delayed response – I tried nulling the fsck per your instructions but it didn't seem to do anything, mounting the disk failed as before, so I removed the line from fstab again.
    – P A N
    Commented Jul 30, 2017 at 13:31
  • Are the permissions of the drive correct? Commented Aug 3, 2017 at 18:37
  • @littletinyman How can I check permissions of the drive? Thanks!
    – P A N
    Commented Aug 8, 2017 at 10:03
  • @winterflags I'm having this issue. Did you resolve it meaningfully? Commented Nov 24, 2017 at 19:21

14 Answers 14


If your ExFAT drive is not mounting, here is the solution.

sudo pkill -f fsck

fsck was holding the disk hostage. A quick ps aux | grep fsck revealed that indeed it was hijacking the disk/volume as soon as it was plugged in. sudo pkill -f fsck (or just kill with the PID if you prefer) immediately allowed the volume to be mounted.

Then to make the hard drive writable, you have to run the Disk Utility "S.O.S.", unmount then mount it again.

  • 4
    This worked for me, +1
    – bafromca
    Commented May 18, 2020 at 4:28
  • 4
    Disk Utility "S.O.S." is just running fsck, isn't it? So, maybe the solution is just to wait and let fsck continue to completion?
    – meelash
    Commented Dec 16, 2020 at 23:33
  • 1
    Why does this happen? Commented Apr 15, 2021 at 18:56
  • 5
    @JBis, exFAT lacks the support of journaling. It allows the file system to keep records of the changes made to the files stored on it. This is useful when data corruption occurs because the logs can be used to recover corrupted data. exFAT does not have this feature, which means that data can be more susceptible to corruption in the event of an unexpected shutdown or the inability to safely eject a removable drive formatted in this way. fsck_exfat can’t mount the disk and will return something like “The volume could not be verified completely."
    – Timothée
    Commented Apr 17, 2021 at 10:11
  • 1
    Read more about exFat pros and cons here minitool.com/lib/extended-file-allocation-table.html
    – Timothée
    Commented Apr 17, 2021 at 10:17

Formatting large volumes exFAT on Windows tends to default to an allocation unit size (read block size) of larger than 1024.

macOS has trouble finding the boot region on disks like that.

Backup your external drive, reformat it under Windows with a block size of 1024, then copy everything back.

  • 4
    I can confirm that after I re-formated my external 2 TB HDD from exFAT with 2048K allocation unit size to exFAT with 1024K allocation unit size, the disk is now discoverable by Mac OS and I can work with it just fine.
    – retif
    Commented Jul 14, 2019 at 14:22
  • That was the cause for me too with a 5TB exteneral drive. The extrange thing is that macOS' Disk Utility and diskutil reported 512bytes of block size (and I can't remember which one I selected back then when I formatted it on Win10 but I tend no to change the default because I'm aware it can cause incompatibilities). When I tried to reformat it again in windows I saw that Windows 10 (ver. 21H1) tries to assing a 2048bytes block size by default for exFat drives. LONG STORY SHORT: macOS disk utilities (GUI & console) probably are reporting wrong block sizes for exFat units formatted on windows. Commented Dec 10, 2021 at 18:15

Just wanted to record my experience for those who follow after...

I have a 4TB WD My Passport, ExFAT, being used on MacOS 10.14.6

It suddenly and unexpectedly did not Mount after a reboot. It was shown in the Disk Utilities app but would not Mount (nothing would happen) and First Aid would not work on it (kept returning an error).

I unplugged it and tried it on a Windows PC and it worked fine, gave a warning about something being wrong but allowed access and it worked fine.

I then did a quick search for ways to force Mount HDDs and foun d another SE page with some useful Terminal commands.

diskutil list

returned this

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *4.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data Storage_001             4.0 TB     disk2s2

I tried the process mentioned on the other SE page, things like;

mount -t dev/disk2
mount force -t dev/disk2

Sadly, that process did not help. Further searches revealed, as expected, it might be an ExFAT on MacOS issue which lead me to this page and the reply from Broski.

I ran the command he recommended and lo! I got a pop-up warning on the desktop about the HDD having mounting issues and then looked in the Disk Utilities app to find it had now mounted A-OK.

So, thanks Broski (I tried upping your comment but am too new to have permission).

Anyone coming late to the party, try the fsck pkill option.

sudo pkill -f fsck

Now to backup and reformat that HDD.



The recent Western Digital "easy store" and "My Book" hard drives have a Mac Sierra 10.12.6 issue: They are invisible to the Desktop.

WD Utilities says my two drives check out ok; Mac Utilities recognizes both hard drives.

Going to the Mac Genius Bar on Monday. BestBuy sold me the original WD easystore 8T and WD sent me a My Book 8T. BestBuy said the WD easystore was dying; a computer technician said no way. Both WD HD's were reformatted ExFat. MacBook Pro Finder cannot see either hard drive.

  • 1
    Good point - some drives do “bizarre things” at the controller level to “protect” data or “enhance” the experience and all most Apple users will want to do is have an easy button to permanently disable those “features” or an easy way to not spend money on them in the first place.
    – bmike
    Commented Nov 10, 2017 at 20:55

I had a similar mounting issue and got the "com.apple.DiskManagement.disenter error". The following command solved the issue:

sudo mkdir /Volumes/External/ && sudo mount -t exfat /dev/disk2s2 /Volumes/External/


On macOS Big Sur, I did some additional steps after following Broski's Answer.

My exFAT Drive was still readonly and MacOS warned me to backup and reformat again. Disk Utility's First Aid didn't work for me. Unmount Mount testing also didn't work.

I found this link to fix corrupted exFAT disk. https://gist.github.com/scottopell/595717f0f77ef670f75498bd01f8cab1

It's very helpful, and I don't need to recover, backup and format my drive. Now, My Files are available to copy and rewrite back.


exFAT (Extended File Allocation Table) file system is the successor to the great old FAT32 file system. It has many pros and cons. One of the pros, for instance, is file size limit's now up to 16 Exabytes. But...

It's not used and was not designed for formatting hard drives. It is only recommended for flash memory storage. That's the only reason it is currently not considered as huge competitor to NTFS on hard drives. Also exFAT contributes to the emergence of permission problems and corrupted files. Suppose your situation is related to this issue.

I would try to reformat it although you've got 8TB to transfer.


This happens with me as well, I'm using a 1TB USB ext drive in exFAT format when suddenly it doesn't mount in my MacBook Pro (M1 - Monterey) but can be accessed from Windows (with Parallel Desktop 18 - Windows 11 ARM).

I've tried all the above steps, but none of them are working. So in my desperation, I plug the USB into a Windows 10 laptop, and I notice a flag in the Disk Management (from this PC, right click, click manage, then click Disk Management) "drive encrypted".

So I go back to my MacBook, plug the USB drive, open Parallel Desktop, open Control Center, select the Windows 11 ARM, go to Setting, add a hard drive, select physical drive, select the USB drive, and boot up Windows 11.

From Windows 11 screen, then I search "device encryption setting" in Windows Start, then turn off the device encryption, it took a whole night to complete the decryption process, then the next morning, exFAT can be mounted back to macOS Monterey. Alhamdulillah!!!


I faced this issue in the latest macOs Big Sur 11.2.1. The disk won't mount or soft eject. I ran Frist Aid option in Disk Utility which took a few minutes since it was scanning the Trancend external drive. After the scan, I had to unmount and mount it back again inorder for the disk to be writable.


I had the same problem on Mac OS Big Sur. Western Digital My Passport for Mac 5TB formatted exFAT. After 6 hours I came back and it had magically mounted. Eject, reconnect, mount OK in seconds.

  • I had exactly the same experience with a Sandisk Extreme Portable. I checked that it was readable on Windows, which it was, and plugged it in again to my Mac. Luckily in my case it was only about 15 minutes that I had to wait before Finder recognised it. I'm now running First Aid on it, to see if that changes anything.
    – AlDante
    Commented Feb 26 at 2:37

The issue seems to be multifold. A thumb drive formated with exfat is being seen as FAT and not exfat by the Mac. Running first aid on the failed partition in Disk Utility fails with fsck_msdos being run...

Running fsck_exfat on the partition /dev/disk2s1 returns fine. Running it on the disk /dev/disk2 fails looking for the boot regions/signatures.

Okay so the issue here is that the Mac is seeing the wrong type of filesystem. We can override.

As others have shown, creating a folder and manually mounting the partition works. This is a workaround to access the files but does not fix the disk.


When connecting the external hard disk, just go to Activity Monitor in MacBook Applications there you can find "fsck_exfat". Double-click on it and click on Quit or Force Quit, then your hard disk will appear on desktop

You can even access this disk on Disk Utility for mount/unmount and whatever options are required.


I haven't tried the fsck approach, and if that works it's faster than this approach, but here's what I've been doing with consistent success:

  1. Start the computer in recovery mode
  2. Select "Options"
  3. Select "Disk Utility"
  4. Select the drive
  5. Restart the computer in normal mode

The drive should now be accessible in Finder.


ref https://tinyapps.org/blog/202203040700_exfat_mount_windows_macos.html, make exfat, then use sudo /usr/local/sbin/mount.exfat-fuse /dev/disk4s2 /Volumes/MyHD,it works for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .