1

I did some partitioning using bootcamp 6.0 to install windows that left a 8 GB of free space with cannot be restored normally, How do I get it back? The diskutils cs list shows:

Last login: Sat Jul 29 16:51:28 on ttys000
AssASSiNxGAs-MacBook-Air:~ AssASSiNxgA$ diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group F57AE880-8554-4F18-B1FC-6291360C2257
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         120368205824 B (120.4 GB)
    Free Space:   8019730432 B (8.0 GB)
    |
    +-< Physical Volume 1A135E2C-54E5-4AA4-9FFA-3444B0E81A47
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     120368205824 B (120.4 GB)
    |
    +-> Logical Volume Family 87ABD6CD-2981-4971-9724-4D7F3CBC95AC
        ----------------------------------------------------------
        Encryption Type:         None
        |
        +-> Logical Volume FD192884-33A4-43CB-86A6-9CE4E58B3B92
            ---------------------------------------------------
            Disk:                  disk1
            Status:                Online
            Size (Total):          111996153856 B (112.0 GB)
            Revertible:            Yes (no decryption required)
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
AssASSiNxGAs-MacBook-Air:~ AssASSiNxgA$ 

My Disk Utility looks like this:

enter image description here enter image description here

  • @klanomath i tried diskutil cs resize and it said iskutil cs resizeVolume /dev/disk0s2 R /dev/disk0s2 does not appear to be a valid Core Storage Logical Volume UUID or disk – xXREKTERxX Jul 29 '17 at 11:54
  • @klanomath what do i use in size option – xXREKTERxX Jul 29 '17 at 12:01
  • @klanomath Thanks! the resize cs worked I used this diskutil cs resizeVolume lvUUID 0 this resized the lv automatically to maximum/fill-fill,but that was completely random,I didn't actually know what it meant but worked anyway. – xXREKTERxX Jul 29 '17 at 12:12
  • Do you want to post the solution as the answer to benefit the community for the next person who has this problem? – Trent Jul 29 '17 at 12:25
  • @Trent klanomoath already did that – xXREKTERxX Jul 29 '17 at 13:00
1

Resizing a Logical Volume in a larger Logical Volume Group with some free space is done with the undocumented coreStorage-verb resizeVolume:

diskutil cs resizeVolume lvUUID size

with lvUUID: UUID of the Logical Volume (the UUIDs are retrievable by entering diskutil cs list) and size (size in b/k/m/g/t | 0 | R)

0 and R are magical sizes and try to maximize the size of the Logical Volume (depends on the system version - doesn't work in all macOS systems).

In your case I recommend:

diskutil cs resizeVolume FD192884-33A4-43CB-86A6-9CE4E58B3B92 120128m

If you get an error disk to small (or similar) choose slightly smaller sizes like 120064m or 120000m until you are successful. The final size of the expanded Logical Volume is slightly smaller than the underlying Physical Volume: some space on the PV is required to store CoreStorage meta data.

Example:

Fusion Drive 3.12 TB:

combined PV size:  3120722 MB
LV size:           3106192 MB
∆ (PV-LV) size:      14530 MB (= 14.5 GB or 0.47%!)
  • yeah you're right in general sense but when it comes to problem like I had using 0 for the resizing job would be better. What do you reckon? (nonetheless it worked for me) – xXREKTERxX Jul 29 '17 at 13:00
  • @Anon IIRC the 0 doesn't work in Sierra... – klanomath Jul 29 '17 at 13:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .