12

I have MBP 2015. I am running Mac OSX Sierra.

I go to my bluetooth preferences and right click and rename a device.

The window for rename comes up. I enter the new text and press rename.

And nothing happens the name of the device just does not change.

No errors ... no warnings.

enter image description here

And the final result (no name change)

enter image description here

1
  • I'm having a different, but likely related, problem with bluetooth device names in High Sierra. My BeatsX earphones stopped displaying the name I gave them in any list of bluetooth devices. In fact, they don't display any name at all! My UE Boom 2 speaker also doesn't (usually) show its custom name, but it does show the default UE BOOM 2 when not connected. – bernk Mar 28 '18 at 20:32
7

It looks like this is bug that show only up for few users. There is no current solution, I event tried manually changing alias name in plist file but it is short term(until you connect next time).

There is more and more people that are having this issue.

In my company we use Macs mostly and I am the only one having this issue. There are already some support questions opened on apples forum: https://discussions.apple.com/thread/7904717 https://discussions.apple.com/thread/7927709

I have even spent 2 hours on phone with apple and they are saying it is not a bug XD

6

I bought a second hand magic keyboard A1314, which uses AA batteries.

I found the following advice on https://discussions.apple.com/thread/251116009?answerId=252423285022#252423285022

  1. Click on the properties of your Magic Keyboard and click on "change name".
  2. Remove the batteries from your keyboard, causing the connection to be disconnected (Or turn it off, according to Gal Bracha's comment)
  3. Type in your new name. The old name will remain but that is only for a while.
  4. Click "done" and put the batteries back in.
  5. Connect your keyboard and check the name.

(Reworded the text a bit for clarity)

I suspect this only works per machine, because I tried it on another macbook and it still had the old name. I repeated the process there and it now has a new name.

Not the perfect solution, but I have no old mac to change the name of the device with :(

1
  • 3
    You can also instead of taking the batteries simply Power off the Bluetooth device - This is a known issue on newer mac os – Gal Bracha Jan 25 at 7:33
4

I also have the same issue with my current macOS Catalina. I could not change the name of my Magic Mouse. Tried resetting with debug mode, turn on and off, delete bluetooth.plist.

Then I tried to connect the same Magic Mouse to my MacBook Pro running on macOS El Capitan, and voila... I could rename it without a problem.

So, it's definitely a bug with the macOS. Not sure since which macOS version the bug existed. But I know for sure that it is okay with macOS El Capitan, and it's not okay with macOS Catalina.

But it might also be a bug combined with the hardware

0

none of these will work. I tried pairing with windows or even older versions of macOS it shows with the original name you want to change. this is definitely related to hardware not related to software. by any chance did you buy this device from a friend or are you using a device you originally paired with your old computer ?

3
  • Welcome to Ask Different. The nugget about your thinking this is hardware can be a solid answer. Might you edit this to reference or explain how someone could validate that statement? – bmike Jun 29 '20 at 4:32
  • if this was purchased used or handed down from friends or family. please ask if they have registered these devices with apple. if they have been registered ask them to go to their apple profile and remove the devices serial numbers from their profiles. once done try to remove the bluetooth device from your computer and pair it again and register it on your apple profile on apple web site – Deniz Atalay Jul 23 '20 at 1:11
  • related: reddit.com/r/MacOS/comments/gftdsz/… – XoXo Jul 30 '20 at 22:17
0

I solved the issue with mine. I was having 100% the same issue.

I tried using old MacBook Pro using Sierra, iMac with Catalina, MacBook Air Catalina and windows 10 (though VMware on iMac running Catalina).

I tried editing plist files etc reseting bluetooth/using debug mode etc etc. none will work.

here is how I worked my issue out. I used an old MacBook (2008) and started installing older versions of Mac OS X until one was able to rename the device names permanently.

it appears once you install 10.7 (Mac OS Lion) it was able to rename the device permanently. to find the root cause I am investigating what changed from Mac OS 10.7 to 10.8 with the bluetooth stack.

but for now the solution to the issue is finding an older Mac using 10.7 and completing the re-naming process there. I hope this helps. If I can pin point the root cause of this I will try to work a fix.

it seems like Yudi Setiawan had success with 10.11 which I also agree Apple seems to have changed something between old versions and newer versions of OS X

I believe I found the root cause, iOS and recent versions of Mac OS X restricts direct access to certain characteristics such as "device name"

this trick based on this should work on android device or a pc running windows natively.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .