88

When I install or reinstall a formula, homebrew automatically update itself before installing the formula.

When working on a slow connection, this is annoying. How can I cancel this automatic update?

3 Answers 3

123

According to this github issue and to the man page, the environment variable HOMEBREW_NO_AUTO_UPDATE can be set to 1.

HOMEBREW_NO_AUTO_UPDATE=1 brew install <formula>

This will stop the homebrew update for this command. If you want to prevent auto update for your shell session, use:

export HOMEBREW_NO_AUTO_UPDATE=1

to set it permanently, add it to your ~/.bash_profile. Note that changing this permanently is discouraged by the developers.

1
  • 3
    This is a contender for the most time-saving answer on stack exchange.
    – stevec
    Commented Jul 28, 2023 at 11:07
12

source:

A better alternative may be instead to set HOMEBREW_AUTO_UPDATE_SECS to a higher value (the default is to try and update every 60 seconds).

export HOMEBREW_AUTO_UPDATE_SECS=<seconds_you_want>

Add the command to ~/.bash_profile to keep the settings for different terminal sessions.

-3

You can also hit Ctrl+C as soon as the

Running `brew update --auto-update`...

message shows up. That's a short-term hack.

2
  • What does this add to the already existing answer (which wasn't well-received) proposing the same?
    – nohillside
    Commented Dec 5, 2022 at 17:02
  • StackExchange ahh comment Commented Jan 30 at 8:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .