1

My dad was running macOS & Windows on his Early 2015 MacBook Air, and both crashed. Apple’s service center said the only option was to reinstall macOS.

Using the Windows Command Prompt I backed up as much data as I could. Then I tried to reinstall Sierra, but couldn’t boot into the Recovery Partition. Internet Recovery never worked (at best it progressed to 10% then stopped).

So I deleted all my partitions and downloaded a Sierra image from someone who put it in Google Drive. I don’t know what I did wrong but it turned my hard drive into an “OS X Base System.”

HDD showing as OS X Base System in Disk Utility

I tried resetting SMC, PVRAM/NVRAM… Nothing worked.

Now when I start the Mac normally it tries to resume the macOS installation, but fails because the HDD contains an “OS Installation Media.”

Then I got my hands on a friend’s Mac that I used to Create a bootable installer for macOS. I now have the USB boot drive, but I cannot boot to it (it shows the Apple logo and then “No Entry”). Trying to boot to the regular HDD also shows “No Entry.”

I would appreciate any help reinstalling my Mac cleanly.

| improve this question | | | | |
  • Are you sure you are booting off the installer? While holding the Option Key did you select "Install macOS Sierra"? – Matteo Jul 27 '17 at 15:44
  • 2
    The Partition Map on the [tiny] photo shows as Master Boot Record, which is incorrect; it must be GUID to be used as an OS X boot disk. Make sure the SanDisk isn't formatted the same. – Tetsujin Jul 27 '17 at 16:14
  • @matteo yes. I am sure I'm selecting "install macOS Sierra'. It does the samething when i try with the hdd too. – Krishna Kotharu Jul 27 '17 at 16:23
  • @Tetsujin i agree. How do i bring back to GUID with my current situation. No recovery options work. Cant boot to usb. – Krishna Kotharu Jul 27 '17 at 16:24
  • 3
    As @Tetsujin pointed out, the partition scheme must be GUID in order for the usb to boot. Go to your friend's Mac again, format the usb and recreate the install media – Matteo Jul 27 '17 at 18:08
1

Here's a guide to get you going again.

Not sure if your question needs to be closed as too broad / too much 20 questions - technical support, but following Apple's erase and install process should fix this at the cost of any data you still have on that drive.

Can't start Mac in recovery mode - only get folder with question mark instead

| improve this answer | | | | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .