1

I just rebooted and for some reason am unable to switch keyboard layouts. This feature had been working previously since just after getting the computer (and setting up the alternate keyboard layout).

The secondary input source is shown here:

enter image description here

My attempt to select the alternate input source is shown here: note I clicked on usd2. However the input source did not change as a result.

enter image description here

I did not do anything related to keyboard settings for quite some time so it is puzzling this problem just showed up. I am on Sierra with MBPro 2015.

  • Do you have Siri turned on? If so, turn it off and change its keyboard shortcut to "none" and restart and see if that helps. – Tom Gewecke Jul 27 '17 at 9:31
  • You are using a custom keyboard layout. Do you have the same problem when using one provided with MacOS, like Spanish or French or ABC Extended? – Tom Gewecke Jul 27 '17 at 9:35
  • Instead of clicking on the input menu in the menu bar, can you change the keyboard via the standard keyboard shortcut Control plus Space (or sometimes Command plus Space)? – Tom Gewecke Jul 27 '17 at 11:43
  • @TomGewecke Siri has always been off. – javadba Jul 27 '17 at 14:24
0

I re-added the same keyboard input:

enter image description here

.. and the second one is working.

enter image description here

I have no idea why this suddenly started failing.

  • Do you have two of them also showing in system preferences/keyboard/input sources? – Tom Gewecke Jul 27 '17 at 17:14
  • @TomGewecke updated the answer – javadba Jul 27 '17 at 17:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .