2

I have automatic updates turned on.

This morning I was prompted to reboot in order to install a new (incremental) update. However each time I reboot I get the Apple logo + installation progress bar that takes about 15 minutes to complete.

enter image description here

enter image description here

Clicking "UPDATE" forces a reboot but fails to advance the situation. I've tried twice. I've also tried a plain old reboot twice.

How to resolve?

  • EDIT: A couple more reboots seem to have sorted it out! I will leave the question in case anyone else starts questioning their sanity after three reboots. – P i Jul 27 '17 at 5:59
  • I am in the same boat. 5 days. Visits to Genius bar......6 time machine rebuilds and the Apple Logo again and again. My advice DONT UPDATE. Wait. I have given up. Clearly a bug. – James Gorry Jul 27 '17 at 9:23
  • same here exactly. pain in the ass. – Matt Reilly Jul 28 '17 at 23:26
1

Download the ComboUpdate 10.12.6 (direct d/l link: macOS Sierra 10.12.6 Combo Update). Open the downloaded dmg and launch the pkg file inside. Reboot when asked.


Alternate solution: clearing the App Store cache often seems to fix the problem.

  1. Quit the App Store
  2. Open Terminal
  3. Run open $TMPDIR../C/com.apple.appstore/
  4. Delete all contents in that folder
  5. Open the App Store again and wait for it to check for updates
  • I have done as you described but no Joy... This results in the same loop and does not clear the update. The OS is showing as the version it wants to update to??? Broken Mac OS update. – J Douglas Cryer Aug 4 '17 at 22:24

You must log in to answer this question.

protected by Community Aug 4 '17 at 22:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .