45

I've googled plenty of guides about disabling spelling and grammar in mac's Notes, and while unchecking the items in the edit menu works fine for the note I'm currently on, it turns back on for each new note and requires me manually disabling it each time.

I would like it to never check spelling and grammar in Notes, and not substitute incorrect spellings (not swapping out for smart quotes and the like would be a bonus). Is there some way to permanently disable these features for just the one app?

To be clear I don't want to disable it system-wide, only in Notes.

1
  • I think you can set up one note the way you like it and then Window → Use as Default will make the new notes use the same settings.
    – Reid
    Commented Nov 5, 2020 at 21:28

3 Answers 3

28

Autocorrect is controlled by the NSAutomaticSpellingCorrectionEnabled key. You can set this in the Notes app preferences for it to apply consistently.

defaults write com.apple.notes NSAutomaticSpellingCorrectionEnabled -bool false

Reset with defaults delete com.apple.notes NSAutomaticSpellingCorrectionEnabled.

4
  • 2
    mac noob here; where do I go to input that setting?
    – Alex
    Commented Jul 26, 2017 at 14:07
  • @Alex You can use the Terminal.app in /Applications/Utilities (or use Spotlight to search for it).
    – grg
    Commented Jul 26, 2017 at 14:43
  • 6
    This didn't work.
    – Esqarrouth
    Commented Sep 21, 2018 at 20:18
  • 2
    Resets after quitting Notes.
    – d0g
    Commented Nov 25, 2018 at 13:29
84
Edit>Spelling and Grammar>Correct Spelling Automatically 

This worked for me. It is sometimes unclickable, if that is the case click a note and write something in this. This action will make it clickable.

2
  • I'm 3 years late but while it looks like this answer is popular, OP mentioned this solution didn't work in their original question: "unchecking the items in the edit menu works fine for the note I'm currently on, it turns back on for each new note". This is certainly the recommended method, but it shouldn't be the accepted answer @Dunc since OP already said it didn't work for them.
    – grg
    Commented Mar 7, 2021 at 18:44
  • Seems to be working fine now (I'm on Big Sur). Unchecking Edit>Spelling and Grammar>Correct Spelling Automatically, no matter what note I have open when changing the setting, the setting is kept when opening other notes or when creating new ones.
    – MrCroft
    Commented Jun 30, 2021 at 6:58
4

In Notes Version 4.8 --> Right Click on Notes --> Spelling and Gramma --> Correct spelling Automatically

enter image description here

1
  • This should definitely be the accepted answer as of 1/1/2024 Commented Jan 1 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .