7

Uploading of Desktop and Documents to iCloud hasn't worked for me for months (macOS 10.12).

I have now started from scratch with a brand-new install, and am trying to sync just ~70MB of files that are sitting on the desktop.

It's been stuck on "77.8MB of 77.8MB" for 3 days.

Why does this happen, and how can I fix it?

I've looked at possible solutions (like logging out etc.), but this is a fresh install, shouldn't it just work?

2 Answers 2

10
+150

All programs are supposed to "just work", however bugs are unavoidable when humans are programming.

With a brand new install it seems that logging out or rebooting the Mac to test if this fixes the problem shouldn't be a problem. So you might want to give that a try.

If you want to fix the problem without logging out or rebooting, try opening a terminal and running:

brctl log --wait --shorten

This should give you a reasonably readable output of log info from the syncing process. Hopefully this will give you a clue as to why the process isn't progressing.

You can also try simply killing the bird process that handles the synchronization. When it starts again it might progress to completion.

3
  • Killing the bird processes (two in my case) from Activity Monitor worked for me. Finder showed an alert about the stuck download failing, but after double-clicking in the file again it downloaded in a breeze.
    – jcabrera
    May 1, 2019 at 21:35
  • 5
    On macOS Catalina 10.15.3, the command does not work as described. Use brctl log -w --shorten instead.
    – intagli
    Mar 8, 2020 at 12:16
  • I have tried your method. It re-indicised and re-synchronised all iCloud, but, at the end, the same 40 files are being synced. Dec 28, 2021 at 15:08
0

for exactly the same problem, raising Bird priority fixed the problem instantly. see iCloud Drive is stuck uploading items and no longer syncs

no other solution was working before (killing Bird, removing CloudDocs)

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .