1

How can I remove a "shared" drive from Finder left bar (and my Mac mini late 2012 computer) under macOS Sierra 10.12.6?

I've tried all the suggestions I can find online, but nothing seems to work. It is a drive called “intel_ce_linux”, and I first saw it after my new Internet Service Provider technician "installed" and checked my new Internet modem. How can I get rid of it completely (i.e. not just hide), please?

I think the guy mentioned something like Bonjour (pardon my French…) while checking the modem, but I am not sure…

This is what I see in my Finder

2

3 Answers 3

5

After much investigation, ultimately this worked for me:

  1. Go to OSX/Preferences/Sharing/
  2. Toggle 'File Sharing' on-and-off in the sidebar
  3. Go back to Finder and see what happens

This seems to force a refresh in Finder, removing old stuck Shared computers. How they get stuck, I don't know. In my case it happened after buying a refurbished Mac and transferring admin rights to my new local user account. The stores' old network computer got stuck in my Shared list.

Some solutions out there involving Finder/Preferences, only serve to hide the unwanted shared computer from the sidebar, not actually removing it.

3
  • This worked for me (toggling on and then off again) and the old mapped network drive (a Windows desktop from some years ago) finally disappeared from Finder! Thank you, was really struggling to remove it otherwise :) Feb 10, 2021 at 7:36
  • Worked for me on 2/9/2022 - good answer Feb 9, 2022 at 20:04
  • March 2022, still the best solution
    – andbi
    Mar 17, 2022 at 4:49
1

Unless you can turn off the modem's shared drive the only way to prevent that from showing up is to turn off all "Bonjour computers" from showing up in the sidebar.

  1. Go to Finder and open a new window.
  2. Go to the finder menu and select "Preferences..."
  3. Click the sidebar icon at the top of the Finder Preferences window
  4. Un-check "Bonjour Computers" and close that window.

Note that will remove any shared device from the sidebar including Windows PCs, other Macs, NAS devices and the like that support auto discovery via TCP.

0
0

I went to Sharing > File Sharing > Options > Unchecked SMB

and this removed the PC from showing in my network! Thank you so much for this lead!

On macOS Big Sur - late 2020

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .