After changing my iCloud account password, which I also use to log in to macOS, I can no longer sign in to Messages which means I can't use iMessage or SMS messages on my MacBook. Every time I enter my iCloud account email and password I get an alert, "This Mac can't connect to iCloud because of a problem with [my email address]." The dialog has a link to iCloud Preferences and if I proceed to sign in there, I then get an error message that my username or password was incorrect (even though I know it's correct). This happens every time I try, the same thing happens with Facetime.

I also can no longer use the iCloud Keychain. I'm frequently (i.e. several times each hour) prompted with "accountsd wants to use the Local Items keychain." which as far as I can tell doesn't exist, so if I cancel that a few times it changes to "accountsd wants to use the iCloud keychain." Entering my iCloud password here doesn't work, I have no idea what the password could be and I don't see any way to set one in Keychain Access.

This is extremely frustrating, I've tried Apple Support but they were unable to solve it, I have an open ticket but nothing has happened for over a week. Has anyone else had a similar issue?

  • Have you tried logging out of iCloud on all of your devices, then logging back in to each of them again? – NoahL Jul 24 '17 at 1:53
  • @NoahL I did try this, didn't seem to work. I was able to resolve the keychain prompts by deleting the folders out of ~/Library/Keychains and when I signed back into iCloud on the device the iCloud keychain came back so I'm good there, but Messages is still telling me my username or password is wrong and Facetime is still telling me an error occurred on activation. I tried signing in to Message on my old MacBook and that still works just fine, so it's isolated to this machine. – bhamrick Jul 24 '17 at 19:43
up vote 0 down vote accepted

I finally went in to the Apple Store and had a "genius" go through it with me. Here's what eventually worked:

rm -rf ~/Library/Keychains ~/Library/Messages ~/Library/IdentityServices
sudo rm /var/db/crls/crlcache2.db

We did like 20 other things before that and got nowhere, I'm not excluding the possibility that resolution was a result of the compounded effect but removing the files listed above definitely was the turning point for me.

  • I sort of have to note that for all of Mac's simplicity and ease of use that this situation (which happened to me similarly a while back) could even occur is a little absurd! – A.fm. Jul 26 '17 at 21:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.