14

I recently bought myself a new Trackpad, since my old Magic Trackpad broke. Ever since, however, zooming (two finger pinch) gets stuck/disabled/not working somehow and, besides rebooting, the only simple solution is go to preferences → Trackpad and disable & enable PinchToZoom`.

It's very annoying, but also strange that his occurs suddenly. This shouldn't be happening. I can't find anything on the web regarding for a permanent fix.

Does anyone else do?

  • Just chiming in to say I have the exact same issue! This started around when I got the new OS X update, around the same time you posted this question. – knzhou Jul 30 '17 at 5:01
  • Sadly haven't found a solution for this.. – Sander Schaeffer Jul 30 '17 at 10:26
  • What macOS are you running? Which version of Magic Trackpad and computer? And you can't think of anything that prompts it? – DonielF Aug 9 '17 at 1:55
  • Hi @DonielF - I'm running 10.12.5. I've an update that I'll be installing right now (10.12.6) which I postponed for a long time. Though, I doubt it'll change anything. I really got no clue what causes this. It mostly happens/notices the error in either Safari, Photoshop or Sketch, as these apps are the ones I zoom in.. It seems completely random. However, it started since I bought the Magic Trackpad 2. Strangely enough, the problem also appears to happen when Bluetooth is off and I'm working on my Macbook alone, away from the Magic Trackpad 2. – Sander Schaeffer Aug 9 '17 at 8:31
  • Hm. And you never took it over to Apple to have them take a look at it? – DonielF Aug 9 '17 at 17:47
2
+100

Since you've already played with your System Preferences, I'd suggest testing to see if this happens while booted into Safe Mode, and also without any external devices connected, including both USB and Bluetooth.

Boot into Safe Mode

Follow these steps to boot your Macbook into Safe Mode:

  1. Fully shut down your Macbook
  2. Restart your Macbook
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. does zoom work on the built-in trackpad when using Safari, Photoshop, etc)
  6. Exit Safe Mode by restarting your Macbook as normal
  7. Again, test to see what happens with zoom etc.

Now, if after you've gone through the above steps you find that:

  • zooming works during Safe Mode but not when you're logged back in normally, let me know.
  • zoom still isn't working during Safe Mode, then it's time to test your hardware with Apple Diagnostics (see below).

NOTE: The steps below are for Mac models introduced from June 2013 onwards. If your Mac was introduced before June 2013, it uses Apple Hardware Test instead.

Run Apple Diagnostics

Follow the steps below to run Apple Diagnostics:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the D key and keep it down until you see the Diagnostics screen appear
  4. Wait for Diagnostics to finish (this typically only takes a few minutes)
  5. Once complete, one of two things will appear on the screen:
    • a No issues found message
    • a brief description of any errors found plus further instructions
  6. If the diagnostics test does find errors, take a note of what they are

Note: If pressing and holding the D key at Step 3 doesn't work, start again at Step 1 and, at Step 3 press and hold both the OptionD keys instead. This will try and run diagnostics from the internet instead, so you will need to allow more time for it to complete.

Regardless, take a note of what happens and let me know how you went.

  • Thank you for your elaborate help in writing such long suggestion. Your tip helps finding out whether the problem is a software or hardware one. However, I think @Jackson1442, with his comment, did the trick actually. I did a quick reinstall without losing data last Wednesday and, although I haven't used my Macbook in the weekend, I haven't had any problem ever since. Not 100% sure I've got rid of the problem, but we'll see. The only 'problem' with your safe mode though, Is that the problem occurred once a day, not after login or within 5 minutes.. Yet, big thanks mate :) – Sander Schaeffer Aug 14 '17 at 12:47
  • That's great! :) And I agree - if the problem was only intermittent and very occasional, troubleshooting steps like booting into Safe Mode can be a PITA, but sometimes troubleshooting just requires, well, a lot of patience! Hopefully the macOS reinstallation fixed it for good! :) – Monomeeth Aug 14 '17 at 12:59
  • Ok, that's a bummer. Every multi-touch gesture works, except for zooming. So the reinstall didn't fix the problem. However, as other gestures work, can I verify that the problem isn't the hardware? – Sander Schaeffer Aug 16 '17 at 11:11
8

All you need to do is go to system preferences > trackpad > scroll and zoom > uncheck Zoom in or out and then check it again.

  • I know, but it gets very annoying when working in Sketch for a whole day and you've got to do that about five times each day. Two OS's and multiple versions of Sketch further and still not permanently Fixed.. – Sander Schaeffer Jul 27 '18 at 14:58
  • okay well would you rather do what the guy above said? – Mars Jul 27 '18 at 14:59
  • This should be the accepted answer to the original question. At least until Apple fixes this issue officially. – MiguelB Apr 9 at 21:56
  • awesome!!! it really helps :) – ruucm Apr 24 at 6:55
7

Do you have Magnet installed?

That caused the same issue for me.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • have had the same problem, after quitting Magnet the gesture starts working again – emmekappa Aug 25 at 10:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .