3

Randomly my dock icons will show the default application icon. Sometimes they return again. I have previously reset the dock and deleted the .plist, which temporarily corrects the problem, but it returns soon enough. Removing and adding the app to the dock again also restores the icon, until the next time. It's tiresome to do this all the time, obviously.

enter image description here

The apps usually affected are the default Mac OS ones. The above screenshot shows my current situation: Mail, Safari, Reminders, iTunes and Terminal are not showing their icons.

I didn't find much on Google by way of people complaining about similar behaviour. Is anyone else suffering, and can anyone suggest a more "permanent" solution?

Thanks in advance.

  • I am still facing this terribly annoying issue. I can add that this issue is present in the Finder as well - usually the same apps are affected in both Finder and Dock, but can also be independent. e.g. The following both possible: Calendar missing icon in Finder, but shows icon in Dock AND Mail missing in Finder and Dock. – Rhecil Codes Oct 31 '17 at 16:09
  • Same here. The problem only started on my Macbook Pro 2014 with the 10.13.2 update. I'm also experiencing this problem with non-Apple supplied apps. This problem also affects the app icons inside LaunchPad. – gone Dec 26 '17 at 6:37
  • Today, after having my MacBook sleeping overnight with the cover closed, the icons in the Dock came back, but LaunchPad still has some defaults showing. – gone Dec 27 '17 at 20:13
0

My most recent attempt seems to have worked, or at least several weeks have passed without the issue repeating, which it previously did within hours, or days at best.

Try these steps:

  1. Reset PRAM and VRAM
  2. Reset SMC
  3. Restart in Safe Mode
  4. Restart normally
  5. Issue fixed? If not, go back to Step #3.

The restarting in Safe Mode is the key here. Resetting PRAM and VRAM is not enough; I had tried that previously multiple times, along with deleting various preference files and caches from ~/Library/ApplicationSupport etc. It didn't work. You may even need to repeat the Safe Mode boot more than once, but ultimately Safe Mode will hopefully sort you out if you are facing the same issue.

  • You got to be joking? – gone Dec 26 '17 at 5:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .