0

I'm using Forticlient to connect to a customer's VPN. It used to work on my MacOS, but it suddendly stopped with apparently no reason. After that I never managed to make it work again on my computer, even it it connects fine with every other device I try (Android, Linux, Windows, another MacOS).

I tried uninstalling and reinstalling several times, but it still fails to connect. I tried removing every single file accessed by the app (checking with lsof) but still fails. Enabling debug I found the following:

20170720 08:27:22.523 [sslvpn:INFO] unknown:0 current uid: 0
20170720 08:27:22.525 [sslvpn:INFO] unknown:0 get current proxy auto config settings
20170720 08:27:22.530 [sslvpn:INFO] unknown:0 use tty:/dev/ttys006
20170720 08:27:22.533 [sslvpn:INFO] unknown:0 connecting to 1.2.3.4:10443 - 10443
20170720 08:27:22.533 [sslvpn:DEBG] unknown:0 tcp connect 1.2.3.4:10443 timeout -1
20170720 08:27:22.542 [sslvpn:INFO] unknown:0 shuting down the running tunnel
20170720 08:27:22.542 [sslvpn:INFO] unknown:0 the tunnel is shut down 
20170720 08:27:22.542 [sslvpn:EROR] unknown:0 connect failed
20170720 08:27:22.542 [sslvpn:INFO] unknown:0 tunnel shutdown -2
20170720 08:27:22.543 [sslvpn:INFO] unknown:0 sslvpn starts to clean up
20170720 08:27:22.547 [sslvpn:INFO] unknown:0 sslvpnd terminated

How's possible it returns timeout right after trying to connect?

I have no firewall enabled on the Mac (10.12.5), I just installed some objective-see apps but none should interfere with network connections.

What else can I check to understand why the connection returns timeout?

0

Happened to be a change I did to /etc/ppp/options to disable IPSec for another native VPN I had.

I added

plugin L2TP.ppp
l2tpnoipsec 

to connecto to a L2TP/IPSec VPN with only L2TP, but with this change FortiClient SSL VPN stopped working.

Commenting out the two lines restored VPN functionality.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .