I'm trying to open iCloud prefs in System Preferences, but I get a preferences error saying "could not load iCloud preference pane" (see screenshot). I have run disk permissions, and even installed a new OS using recovery mode, i can however open iCloud prefs using another user account on the same computer, any ideas anyone?

enter image description here

  • 'First fix' would be to get the Combo Updater for your current OS version & run it. Google for "Combo update 10.11.5" or whatever is appropriate - that should find it on Apple's site. Installing over recovery was presumably followed by a restore - which is likely to have re-imported whatever went wrong. – Tetsujin Jul 19 '17 at 19:22

Well you have already given us the first clue as to where the issue is:

i can however open iCloud prefs using another user account on the same computer

While it is possible that a combo updater will fix the issue it is more likely (IMHO) something specific to your user profile. How I would do it.

  1. Hold down the Option key while in Finder and select "Library" from the Go menu.
  2. You want to look for items with "icloud" in their name and move them elsewhere. I usually use the desktop or a folder on the desktop.
  3. There will be files in "Preferences" and "Application Support" and possibly elsewhere. Don't remove the folders, just any files within making note of the path each file was at.
  4. It is possible that there are other files in the same locations that deal with iCloud. poke around and move ones that might qualify.
  5. Once that is done, reboot and try opening that preference pane.

Note that you don't just delete the file in case the law of unintended consequences rears it's ugly head. So if things get worse put the files back. But I am betting that won't happen.

I am thinking that there is a damaged preference or icloud support file somewhere in your user folder and "/Users/[USERNAME]/Library/" is the most likely place for said file to be.

A reboot should cause macOS to rebuild the missing files and opening the iCloud preference pane should finish the job.

Note that it is possible that you will need to re-enter your iCloud account information once you get it working.

  • Thanks Steve, I'll have a go at your suggestions over the weekend. I will of course let you know how I progress – user247074 Jul 20 '17 at 18:45
  • Hi Steve, I tried your suggestions last night and unfortunately it didn't make any difference, any further ideas would be most welcome – user247074 Jul 26 '17 at 13:13
  • Create another user account and migrate your documents and whatnot to the new user. Once everything is over, delete the old user account. Sorry thats all I got... – Steve Chambers Jul 26 '17 at 15:47

Try to go Preferences, then Internet Accounts and then disable and re-enable the iCloud. That worked for me.


Go to applications/utilities and run the console. On the left select 'system log' Hopefully errors are not happening so fast messages are flying by to fast to see or it will be harder to find what you want.

Make sure System Preferences is closed. Click Insert Marker in the menu bar. Open System Preferences. Click Insert Marker in the menu bar. Click to open the iCloud pane. Let it put up banner, crash, etc. Click Insert Marker in the menu bar. Close System Preferences. Click Insert Marker in the menu bar.

Select all the messages from and including the 1st and last markers.

You can file, save selection as, and it will save a log file you can click on and open with the console to read it. Or copy the selected text and past it into a text file.

Read what happened, it will give you a clue or even tell you exactly. Often there are permission issues and a file could not be written to or read.


I think it happens once you modify the computer, as in change the HDD to an SSD and then use time machine to get all your data back. My iCloud preferences pane was not opening, my messages and FaceTime were frozen as well.

I had created a new admin account, signed out of my old iCloud folders and basically started afresh with a new user account and viola, all is working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .