1

I have an iPhone (iOS 10) and a macbook (macOS 10). My SMS/iMessages used to be in sync between my computer and my iPhone.

At some point, not sure when, they stopped syncing.

  1. Both devices are connected to my Apple ID.
  2. Handoff is enabled.
  3. iMessage is enabled.

enter image description here

1

First of all, I've had a less than prefect experience with messages being delivered to both Mac and iPhone which I largely attribute to non-Apple devices.

To your problem, have you tried un-ticking phone numbers/email accounts and signing out on both devices? Quit app then re-lauching and signing back in?

1

Is it ALL your messages that stopped syncing, or just SMS? If it's just SMS, on your iPhone open Settings / Phone / Text Message Forwarding and make sure your Mac is checked. If it already is, uncheck it, wait a minute, then check it again.

If your Mac isn't receiving iMessages, try signing out of iCloud on your Mac, maybe reboot, then log back in.

  • 2
    You're onto something. It is currently disabled. When I try to turn it on, it says to enter the passcode shown on my mac, but nothing is shown. It triggers my Messages app to load, but no passcodes. I restarted both the iPhone and the Mac... – nute Jul 19 '17 at 12:26
  • 1
    You may need to sign out of iCloud and back in on your Mac. – user19754 Jul 19 '17 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .