1

I have updated to 10.12.5 yesterday and I am facing some issues with Time Machine and volumes where the backups are stored. I used to have two Volumes where Time Machine backups are stored:

  1. network volume
  2. usb drive

The first problem I faced was that all the backups, either on network or on usb drive, stuck on "preparing backup" state.

I tried these solutions:

  1. reset Time Machine (removing /Library/Preferences/com.apple.TimeMachine.plist
  2. reset SMC and NVRAM

Nothing changed. Except for the fact that, since I reset Time Machine, my Volume with usb backup partition (HDMac) is not mountable anymore. Giving sudo lsof | grep disk2s2 I understood that system stuck on fsck_hfs. While backup on network drive is still on "preparing backup".

Can anybody help me?

  • 1
    Did you upgrade to Sierra from 10.11.x? This would change a lot of files which could result in a longer than usual preparation step – nohillside Jul 18 '17 at 9:31
  • @patrix: yes I updated from 10.11.x. But Time Machine stucks on "Preparing backup" for more than two hours. Is it a normal behavior? – delca85 Jul 18 '17 at 9:33
  • 1
    Hmm, it may take hours. And after resetting TM it may take longer if some of the disks need to be checked first – nohillside Jul 18 '17 at 9:51
  • @patrix ok, so I am going to wait. Thank you very much! – delca85 Jul 18 '17 at 9:53
  • 2
    If you've solved your problem, write an answer and accept it – grg Jul 18 '17 at 11:07
1

The solution for my problem was simply waiting for some hours in order to obtain the backup.

To repair my usb drive I ran fsck_hfs -fy /dev/disks2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .