3

I can't seem to access software updates on my Mac. When I go to 'App Store' on my Mac and check the Updates tab, it spins for a long time, then a dialog box pops up saying

An error has occurred

Can't load data from the Apple Software Update server.

Things I've already checked:

  • This doesn't seem to be a network problem or transient fault. It has been happening for the past week or more. I do have network connectivity (ping 8.8.8.8 succeeds, and I can load web pages in the browser).

  • I can view the other tabs of App Store without problems.

  • I've tried signing out from App Store, quitting it, re-launching it, and signing in again, but that doesn't help.

  • I've tried running softwareupdate -i -a from the command line, but that doesn't seem to help: it prints "Finding available software", hangs for a long time, and then quits without printing anything. Adding the --verbose flag doesn't help provide any additional information.

  • I am using MacOS Sierra version 10.12.4, if that's relevant.

How do I troubleshoot this?

1

Please try this guide. At least it was useful for me.

By default, the built-in application firewall for macOS automatically allows applications signed by Apple to receive incoming connections. If you've adjusted the settings for your application firewall, you might need to allow incoming connections. If the issue persists, reset the cache of accepted certificates:

  1. Click your desktop to make sure that you're in Finder.
  2. From the menu at the top of your computer screen, choose Go > Go to Folder.
  3. In the box, enter /var/db/crls/.
  4. Click Go.
  5. Drag the files labeled crlcache.db and ocspcache.db to the Trash.
  6. If prompted, enter your administrator password.
  7. Restart your computer, then try to connect to the iTunes Store, iBooks Store, or App Store.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .