1

I have a Windows 7 Pro PC and want to share its drives so my Mac with Sierra installed can see it.

The PC is named "PC", it's on a workgroup called "WORKGROUP" and the only user on it is called "Tim" and this user has never had a password created for it. The Windows username is therefore PC\Tim. I checked the Guest account also and it's enabled now.

I went to the root of the drive I want to share and set the Everyone user to have FULL CONTROL. I set up advanced sharing so that the drive was shared from root and has "everyone" as "full control". This is how I want it.

On my Mac I want to connect to it via its IP address. I open the "Connect to Server" box and type in smb://192.168.1.106.

This prompts with the "connect as" box but I can't get past it. I've tried selecting Guest which goes to the "problem connecting" screen. I've tried the names tim, Tim, pc\tim, PC\Tim and none of these work.

I tried setting up a new account on the Windows 7 PC, called "MAC". It has a password, which is MAC. I added the user MAC as full control on the root of the drive I want to share. I added the user MAC permission in the advanced sharing screen and ensured that it had full permissions.

The prompt still refuses to authenticate the users.

Note: I also tried connecting to cifs://192.168.1.106.

So. Is Sierra Mac just no longer able to connect to Windows computers?

/edit

I've noticed this error message in the console during the time it's tryign to authenticate. I've also confirmed that YOSEMITE will connect just fine: This only affects SIERRA.

RPC to srvsrvc gave error 0x16c9a034

Googling this leads to a rather unhelpful Apple article.

  • Maybe try this - apple.stackexchange.com/questions/152900/… – Tetsujin Jul 15 '17 at 10:51
  • Nope. For me this has FIXED Yosemite connecting to Windows 7, but Sierra is still unable to connect. – frumbert Jul 16 '17 at 0:31
  • Here the Win7 share works right out of the box - with nothing (or the defaults) set in Win7's Local Security Policy > ...> "Network security: LAN manager authentication level" – klanomath Jul 16 '17 at 19:04
  • Upgraded Sierra to 10.12.6. One of the fixes was "connecting to smb shares". Has had no effect - still broken. :-/ – frumbert Aug 1 '17 at 11:51

You must log in to answer this question.

Browse other questions tagged .