0

I've got an iPhone 6 running the iOS 11 public beta, and a few days ago, it suddenly stopped being able to play any audio or video unless it's through Bluetooth headphones. When I try to play a song, it says "The operation could not be completed. An unknown error occurred (-12746)." The player then proceeds to open the next song of the album, then the next, then the next, as if every song there had a length of 0:00. Trying to play a TV show throws the same error message, and when I try to play videos through third-party apps like Facebook our YouTube, they simply don't play, and my phone is so audio-free that I can't even hear people on the other end of phone calls.

All of these errors go away when I connect to my Beats Solo3's, but they happen all the time when I'm trying to use my phone's speakers or wired headphones. I've tried a reboot, a hard reset, and a wipe and downgrade to stable iOS 10, but nothing's fixed the issue.

By that point in my troubleshooting, I'd resigned myself to having an iPhone with a hardware issue for a few more months until the new iPhones come out, but then the really weird part happened: For the past couple days I've been carrying around my old 5th-gen iPod Touch (stuck on iOS 9.3.3) so that I can answer phone calls through Continuity and play music through my car's aux cable on my long drives to work, but this morning, it somehow manifested the exact same issue. Even weirder, doing a simple hard reset (just holding down Home and Power until the iPod rebooted) fixed the issue, at least for now. Again, the issue has survived multiple hard resets on my iPhone, but a single one on my iPod fixed it.

Google seems to have no idea what's causing this, and I'm totally stumped. Does anyone know what this issue is and how I can fix it, if possible? Thanks!

  • 1
    You're running a beta version of iOS. File a bug report from the built-in app. – IconDaemon Jul 14 '17 at 20:12
  • @IconDaemon I'm still wondering how my iPod (running stable iOS) caught the issue, even if it was fixable there. – user24601 Jul 14 '17 at 20:14
  • You indeed have a strange problem. The only common factor is the Beats headphones. Have you ever connected your Beats Solo3's to the iTouch? Have you deleted the Beats device from the Bluetooth list of devices, (and all other BT devices, too,) to see if that makes the problem go away? – IconDaemon Jul 14 '17 at 21:00
  • @IconDaemon I’ve never connected the Beats to my iPod. The one thing they have both been recently connected to is my car’s aux cable. Is it possible an aux cable could seriously damage a device like this? – user24601 Jul 14 '17 at 22:14
  • "Is it possible an aux cable could seriously damage a device like this?" Well, if there was DC current accidentally coming over the aux cable from the car system, it could potentially fry something inside the device. This is all just supposition, though. Good luck, @user24601, and good night. – IconDaemon Jul 15 '17 at 1:13

You must log in to answer this question.

protected by Community Jun 30 '18 at 19:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .