2

Why does my laptop camera keep losing picture? Is this possibly just a hardware failure? Specifically, this is in regards to a mid-2012 MacBook Air running macOS Sierra 10.12.5 with a 2GHz i7 & 8GB RAM. The laptop has led a pretty sedentary, suburban life (not banged around a lot or used on the go). Maybe it's just five year old ribbon cables from the camera through the laptop hinge finally giving up?

As of today, the camera picture just isn't coming back. None of these get me picture again:

  1. zapping the PRAM:
    • hold down +option+p+r while booting/restarting...
    • let the mac chime 3-4 times, then let go.
  2. Disk Utility's First Aid in recovery mode (or internet recovery mode):
    • +r, or,
    • +option+r at bootup
  3. resetting the SMC (System Management Controller):
    • shut down, unplug power, hold SHIFT+CTRL+option+POWER for ten-fifteen seconds then boot up.
  4. Apple Hardware Test:
    • Restart holding down d
    • Running the basic test, and, running the extended test just result in the message: 4HDD/11/40000000: SATA(0,0) for a computer which does not have an HDD...
  5. note: invoke these commands until the return msg appears $ sudo killall VDCAssistant
    No matching processes were found
  6. sudo killall AppleCameraAssistant
    No matching processes were found

... no picture, but the camera is still detected on the USB hub:

enter image description here

After zapping PRAM, resetting SMC, recovery mode Disk Utility:

After zapping PRAM, resetting SMC, recovery mode Disk Utility:

After sudo killall VDCAssistant:

After <code>sudo killall VDCAssistant</code>

OF NOTE:

  • I'm not sure, but I don't think AppleCameraAssistant is a thing anymore in macOS Sierra?
  • Also, takes a couple invocations of $ sudo killall VDCAssistant to get the No matching processes were found return message. I have no apps open which use the camera, so I am not sure why this happens.
  • sudo Killall VDCAssistant does nothing except, for example, PhotoBooth.app or FaceTime.app change from a completely black screen to a black screen with the "There is no connected camera." message. The camera still detected on USB 2.0 bus and after restarting, the app displays a black screen with no "...no connected camera" message.
  • Even when the picture is missing (with or w/o the "no connected cam" msg) and there's no green indicator light, the device is still detected on the USB bus. There's no picture in PhotoBooth, FaceTime.app, or meeting software like zoom.us.
  • Restarting in Recovery mode and using FirstAid in the Disk Utility used to resuscitate the camera, but after a couple uses, launching an app that accesses the camera would result in nothing but a black picture and no green indicator light.

Any suggestions for troubleshooting would be very welcome. Thanks you.


UPDATE: the camera functionality has "magically" reappeared and is now consistent. I think it might be the connecting wires. I noticed after traveling that the camera went away. I gently tapped on the hinge side of the laptop with the Air book closed, and that got it working again.

  • What does rebooting without First Aid do? – Tetsujin Jul 13 '17 at 8:19
  • @Tetsujin nuthin. – Mr. Kennedy Jul 13 '17 at 8:31
  • Then you need to try figure out what needs fixing each time. .. then what's breaking it. – Tetsujin Jul 13 '17 at 8:35
  • @Tetsujin Are you aware of any non-expert level means to capture the entire state of my computer with the camera working so that I may capture the state of it when it stops working and examine the Delta? – Mr. Kennedy Jul 13 '17 at 13:56
  • I suppose enabling the Disk Utility debug options might be a starting place... – Mr. Kennedy Jul 13 '17 at 14:33
2

Just wanted to chime in and say that this also just started happening to me. I'm on an identical system: 2012 MacBook Air, 2Ghz i7, 8GB RAM, running 10.12.5. I managed to fix it yesterday but it happened again today. I think it has something to do with the Zoom.us video meeting software? Very annoying since I just started a new remote job where I need to have Zoom meetings with folks fairly regularly...

  • Welcome to Ask Different. Please refrain from adding comments in the Answer section. This is for answers to the questions only. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. See How to Ask for more info on how to ask a question. – fsb Jul 19 '17 at 22:21
  • Thanks. I only recenlt started using Zoom, but I had been having issues with the camera prior. Did you try all the steps - pram zap, repair disk first aid, sudo killall VDCAssistant, etc? In addition to fsb's comment, if you feel it was a useful question, please upvote :) – Mr. Kennedy Jul 20 '17 at 2:43
2

You most likely have a hardware failure of the Facetime camera.

It doesn't have to show up in AHT for there to be a problem. Like any test, AHT isn't immune to false positives/negatives.

To truly verify if it's your hardware or software, install a generic USB camera (FaceTime camera is technically a USB camera) which uses the same underlying software as the FaceTime cam. If it works, it's a hardware issue.

Regarding your AHT error code indicating a bad drive; just because it uses the code "HDD" doesn't mean it's not applicable to SSDs. An SSD or HDD uses the exact same ATA command set to interface with so if you are getting an error code it is valid and applicable.

Again, AHT is not the definitive answer, but a tool to help you diagnose problems. If it's giving you an error code, it's something you should start looking into.

  • Thanks Allan, oddly enough, the camera functionality has "magically" reappeared and is now consistent. I think it might be the connecting wires. I noticed after travelling that the camera went away. I gently tapped on the hinge side of the laptop with the Air book closed, and that got it working again. – Mr. Kennedy Apr 27 '18 at 13:52
  • Tapping on something to make it work sounds like a bad connection issue. If it's the hinge, it's probably the cable that's failing. After all, it's constantly flexing back and forth with every open/close of the lid. – Allan Apr 27 '18 at 13:55
1

I am having this exact problem too. Im on High Sierra with no previous problems. Last night I tried installing Nvidia Web Drivers and CUDA to try and get TensorFlow GPU CUDA working on Mac. Since then the webcam doesnt work. I have tried upgrading, uninstalling etc of the NVIDIA stuff but nothing so far.

I am downloading the combo update now, fingers crossed. There is clearly something missing software wise but no way to tell OS X hey, refresh the FaceTime drivers etc.

This is really annoying!!! I followed all the guides which talk about disabling or re-enabling the webcam but im missing this file: QuickTimeUSBVDCDIgitizer.component however, I checked on my macbook air with High Sierra and it also doesn't have that file and the webcam works fine.

Any help would be welcome!

EDIT: So I installed macOSUpdCombo10.13.4.dmg and its fixed! :)

  • 1
    So I installed macOSUpdCombo10.13.4.dmg and its fixed! :) – Madhava Jay Apr 26 '18 at 19:56
  • Please add this comment to your answer or I will be forced to flag as not an answer. – JBis Apr 26 '18 at 21:23
  • @Josh "Forced"? Really? Do you know that you have the option to edit answers? "Any help would be welcome" - including, help to keep Stack overflow epistemically focused. – Mr. Kennedy Apr 27 '18 at 13:46
  • @MadhavaJay Welcome to Apple Stack Exchange! Josh makes a valid point, the Stack Overflow model is a Question and Answer format, not an "open dialogue" forum. To make your answer more focused on addressing the question, it would be great to edit your answer and include your solution :) Thanks for adding useful information to this Question! – Mr. Kennedy Apr 27 '18 at 13:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .