I have Windows 7 SP1 Home Premium x64 installed under Boot Camp 4.0 in OS X Lion (10.7.2) on the 2011 Mac mini and it's also hooked into Parallels Desktop 7 as a VM when I need it in OS X.

An interesting problem I've noticed lately is that when I'm in Boot Camp any window that gets maximized will maximize past the Taskbar and therefore cover the contents of the bottom of the window. This behaviour applies not only to maximized windows but even windows that are set to open at the bottom of the screen but usually stick to the Taskbar as a boundary (i.e. run prompt). This has become irritating as I use Download Statusbar in Firefox as an example and I can't access the downloads if they're covered by the Taskbar without hiding it first.

The reason I brought up Parallels Desktop earlier is because the Taskbar acts normally in VM state. Windows will adhere to the Taskbar as a boundary and everything works as expected. Only when I'm in Boot Camp does it ignore the Taskbar as a boundary and maximize the window to the edge of the screen.

I've tried a number of solutions Google has given me including unlocking/locking the Taskbar, moving the Taskbar around, modifying some Registry entries but nothing has worked. What did end up working as a last resort was reinstalling the Boot Camp partition but the problem came back later on.

Anyone here have some insight as to what may be going on with the crazy Taskbar and possibly a way to fix it?

  • I to am having the same problem. Although my version of BootCamp shows as 3.3 (could not find a version 4 available). I am running Snow Leopard on a MB Pro with Parallels 7 and Windows 7 Business. I am using BootCamp a little more recently but do not recall this being a problem prior to installing the latest Parallels. No referece to this problem on the Parallels support site as of yet.
    – user13124
    Nov 2, 2011 at 14:24

1 Answer 1


Problem finally solved. I read your article, and like you, I have been searching the internet for a solution. Your article inspired me to try and uninstall Parallels Tools, as I thought it might have set up some strange settings. And after I uninstalled Parallels Tools, all was fine again. My windows are once again maximizing correctly. This is bad news however, as I also want to use Parallels Tools when I run in OSX. Guess I have to go back to VMware Fusion or hope a newer version of Parallels Tools will fix it.

  • Also consider VirtualBox, which is free and can read the Virtual HDD format of VMWare and Parallels Jun 25, 2014 at 3:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .