18

I'm trying to enable the Sunset to Sunrise option for Nightshift. When I do so, a pop-up informs me that it "requires location for time zone to be enabled," and offers a button to send me to the appropriate privacy settings page. Here's a screenshot of the pop-up.

Night Shift error

But the privacy settings appears to have no option corresponding to what's referenced in the pop-up. Here's two screenshots showing my privacy settings:

privacy settings 1 privacy settings 2

As far as I can tell, all privacy settings are enabled, but Night Shift still refuses to enable sunset to sunrise. Does anyone know how I can enable it?

  • 1
    Have you rebooted since you checked the time zone setting box? – Jackson1442 Jul 11 '17 at 20:08
  • That was it. I didn't think to reboot and I don't remember anything prompting me to, but it may have. – user110524 Jul 11 '17 at 20:17
  • This is still a problem, it looks like. No matter what I turn on or turn off or reboot, it just doesn't work -- same behavior. – jesdynf May 6 '18 at 5:06
11

Reboot.

Sometimes, settings don't come into effect until you reboot your device, especially if it's a system-wide preference. Rebooting tends to solve most System Preferences-related issues.

Sometimes, System Preferences won't tell you to reboot your device, but if something isn't working, rebooting should solve your issue.

Night Shift location services do not take effect until your computer is rebooted.

  • 2
    BLARGH. It's an apple setting to satisfy another apple setting on an apple device. C'mon. – doublejosh Sep 27 '17 at 19:49
  • 3
    Rebooting did not solve it for me. – William Entriken Jan 30 '18 at 15:53
  • 1
    Although this is the accepted answer, at least as of macOS 10.13.6, it's incorrect. See the other highly-voted answer, which explains how to fix this without rebooting. – Tom Loredo Jan 23 at 1:23
22

Rebooting didn't help and I couldn't get Apple's official instructions (https://support.apple.com/kb/PH26239?locale=en_US) to work, either.

I ended up unchecking "Setting Time Zone", rebooting, and then rechecking "Setting Time Zone" after the reboot. Selecting Sunrise to Sunset was then accepted without complaint.

Here are the complete instructions, using variations on Apple's official instructions:

Uncheck the Setting Time Zone option: Choose Apple menu > System Preferences, click Security & Privacy, then click Privacy. Select Enable Location Services, scroll down to System Services, click Details, deselect Setting Time Zone, then click Done.

Reboot (Although I'm not sure this step is necessary, it's what I did.)

Check the Setting Time Zone option: Choose Apple menu > System Preferences, click Security & Privacy, then click Privacy. Select Enable Location Services, scroll down to System Services, click Details, select Setting Time Zone, then click Done.

  • my location services were disabled and enabling fixed it (macOS 10.13.6): Apple menu > System Preferences, click Security & Privacy, then click Privacy > >click the lock icon to unlock preferences > check "Enable Location Services" – Chris Smith Jul 27 '18 at 3:40
  • 7
    I just followed this sequence without rebooting, and it worked. So, uncheck the Setting Time Zone option, exit settings, return to settings, check it, then turn on Night Shift. – carbocation Aug 10 '18 at 3:11
  • 1
    I think the trick may be unlocking the Security & Privacy page before trying to enable "Sunset to Sunrise." – jelder Nov 5 '18 at 2:10
  • 1
    Just want to echo @carbocation: You don't need to reboot (at least for macOS 10.13.6 on a RMBP), but you do need to uncheck and recheck the time zone option. – Tom Loredo Jan 23 at 1:22
  • @jelder I tried unlocking the Security & Privacy first and it still didn't work. I think you have to actually uncheck/check. – Jon-Eric Jun 14 at 16:26
1

Here's another "privacy setting" that's relevant:

enter image description here

0

You need to have your Wi-Fi connection on, so the system can find your location. I was just using Ethernet and had Wi-Fi turned off so it couldn't properly locate me. You'll probably also need a restart after the location locks down, but I haven't tried that yet.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

0

Unchecking the Setting Time Zone then changing Night Shift option to location works without rebooting on Mojave.

0

in time zone setting untick set automatically time zone base on current location

and set manual time zone base on your location.

and then set sunrise to sunset. it's work

0

Final answer:

  • Uncheck "Setting Time Zone"
  • Recheck "Setting Time Zone"

Shame on Apple to have us do that..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .