10

I have a late-2013 Retina Macbook Pro running Sierra 10.12.5 with a myriad of issues that I've been trying to work out. Today's problem: First Aid says there are problems with the partition map that might prevent booting, and to fix them, I need to run First Aid from Recovery. Easy enough.

So I boot into Recovery and run First Aid and get the same message: run First Aid from Recovery, even though I'm already in Recovery. I get the same message in Internet Recovery and when running Disk Utility off an external macOS installer USB. How can I get First Aid to run in Recovery?

1
  • The error message might be dumb. What happens when you repair the Macintosh HD, then the Disk that contains the HD, then the Macintosh HD a second time? Clean run the final time?
    – bmike
    Commented Sep 30, 2017 at 23:03

3 Answers 3

3

I think it means restart from Internet recovery. Because the disk containing the recovery partition you are running disk first aid from needs repair. So reboot while holding commandR. Give your ethernet or wifi password if needed.

This just happened to me.

edit to fix key sequence.

edit I missed that you were already in Internet Recovery. Depending on the error, it may just be uncorrectable.

7
  • 1
    It's CMD+ALT+R. This works fine though, the message you get from Disk Util is really bad.
    – Marv
    Commented Oct 2, 2017 at 0:34
  • @Marv correct. I updated this (I'd prefer to use option than alt, despite what the paint says) Commented Oct 13, 2017 at 19:33
  • 1
    I first tried command+option+r and that showed the Internet Recovery globe animation, but still gave me the same error. I then tried command+shift+option+r and that showed the same globe animation, but then started in me in an older recovery version that allowed me to repair the disk.
    – donut
    Commented Sep 25, 2018 at 15:35
  • None of these key sequences worked for me unfortunately Commented Jul 2, 2021 at 18:16
  • 1
    @StevenR.Loomis Whatever key sequences I was using, they were booting me in an older recovery version which didn't support APFS or whatever filesystem was on the disk. I needed to go back to the newer recovery version. I don't remember how I did that, I just kept trying different keystrokes until I got it to work. I did not need to boot from an external recovery disk. Commented Jul 30, 2021 at 16:48
-2

Mount the drive below the physical drive name then check that via first aid worked well for me

-3

Restart your Mac in Recovery Mode by holding down Cmd+R immediately after the chime. You'll booth into Recovery Mode and you'll see Disk Utility as an option. Run Disk Utility, select Macintosh HD and run First Aid.

More details: https://support.apple.com/en-us/HT201314

1
  • 2
    You did not answer his question. He was already in Recovery Mode.
    – Gray Adams
    Commented Aug 9, 2017 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .