I just received a new MBP 2017 (14,3), which has only USB-C ports. I have a passive Lention USB hub, which allows me to plug in traditional USB devices e.g. a thumb drive.

I want to dual-boot Linux on this machine. I've created a bootable thumb drive with Linux on it. The problem I'm having is that on reboot, when I press the option key to show me boot devices, the thumb drive does not show up. This has worked fine in the past with older models of MBP.

What should I do to get around this?

My only thought is that the machine is not able to enumerate devices on the hub. I don't currently have a USB-C -> USB adapter. Has anyone else experienced this and if so, what did you do to overcome the issue?

The passive hub works perfectly when in use in OSX.

  • Hi Jim, welcome to Ask Different! :) Can you clarify the exact model of passive USB hub you're using? And, is this hub working otherwise when connected to your new MBP?
    – Monomeeth
    Jul 9, 2017 at 3:29
  • Edited to answer @Monomeeth 's questions.
    – Jim
    Jul 9, 2017 at 5:54
  • did you try try the UFI boot option thats where linux boot disks show up on my machines not like B4 where they would show up as usb devices sorry its not an answer but I cant comment
    – Junme
    Jul 11, 2017 at 5:10
  • Does that require me to run refind first? Perhaps it does. I haven't installed refind yet because I figured Linux needed to be installed first. I'll try that out, though, and report.
    – Jim
    Jul 11, 2017 at 19:48

2 Answers 2


up for one answer above, plus make sure that the adapter you're using is the right adapter for running the external hard drive's operating system. I had a 2015 MacBook Pro and I was running kali linux on an external hard drive. I was forced to buy the 2017 version since my dad needed a new computer and he wanted the 2015 MacBook I had. I mindlessly just picked out a USB-C to USB adapter, and that adapter worked for reading and transferring files from different hard drives, but when I try booting the kali linux hard drive, it would ask "which hard drive to boot" after pressing the option key, but it would end up having a black screen when I chose the kali. I almost deleted the kali linux operating system I had, and all the files in it (repeat/repartition drive, etc) but a light bulb came to my head and prompted me to check the box of that stupid adapter I bought...sure enough, it was only a USB-C to Type A USB. This may not be the same case for you, but my problem was solved when I bought a different adapter for the USB-C connection for the 2017 Mac.


I purchased one of these USB to USB-C adapters from Amazon. This solved the problem. I was able to plug in the thumb drive through the adapter and start the liveCD version of Ubuntu by pressing the option key on reboot and selecting EFI boot. Now the problem will be getting drivers to work for all of the hardware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .