2

When I send an iMessage from my phone, it appears to come from the phone number for that phone, and as a result, when it is replied to, the replies (and the conversation) appear only on the phone; but when I send an iMessage from an iPad, the message appears to come from an e-mail address, and as a result, the conversation is replicated across all iOS devices using that e-mail address.

I may not have that quite right (it requires some cooperation to test, and I can find no documentation that confirms it) but if I do:

Is there a way to "force" an iMessage to "come from" an e-mail address rather than from a phone number, so that I can ensure that a conversation is synced across my iOS devices?

4

Yes, under Settings -> Messages -> Receive At -> Caller ID you can set the phone number or email address you want your messages to appear to come from.

You can also do this with FaceTime as well.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .