10

A few days ago I decided to update to Sierra from El Capitan on both the disks on my MacBook Pro (mid 2012); the update on my SSD went without a hitch so I decided I'd update my other disk, too. I downloaded the .app and the installation started as normal; once it got to the point where I'd have to restart, though, the problems started.

Once the Mac booted, a folder with a question mark appeared; I read that resetting the VRAM and choosing a startup disk (again?) helps in these cases, and it did; however, now I get a prohibitory sign whenever I try to log in on my hard disk. To be exact, it happens after I insert the login password and the loading bar is almost full.

Is there some way to gain back access to the volume, or even just access to the files? I have 100GB+ of Photos Library that I really don't want to lose.

Here are some of the things I tried:

Basic Fix & Repair Options : from both the terminal and Disk Utility, on both Single User Mode and Recovery Mode. The "Repair" option in Disk Utility, in particular, gives this error: "File system exit code is 8. An internal error has occured". Trying to Mount the volume, in whatever way, has no effect whatsoever or I just get an error that the volume can't be mounted. Also, the partition now shows up as greyed out and called "--" (empty); it was called "Macintosh HD". The name still appears in several other disk utility apps, but still something to note.

Recovery Mode : I tried re-installing the OS but the volume is now unmounted so it doesn't show up as a possible option. Also, I found an article saying that booting problems could come from old extensions that no longer work after an update; the article described the terminal steps to take in order to move all non-Apple extensions to a folder on the volume and make it bootable again. However, same problem, the volume is unnamed and unmounted and it doesn't show up anywhere, nor can I "cd" into it.

Safe Mode : I can't start Safe Boot into the damaged partition: to load it, I need to hold the Option key and choose it from a list and doing that and holding Shift too doesn't do anything. I can only boot in Safe Mode on my working OS X partition (SSD) and that defeats the purpose. Thinking about it now, is there a way to Safe Boot into a different disk/partition?

Single User Mode & fsck : I ran the fsck command (and variations) multiple times on the faulty partition and others, too, and at some point I got a "GRUB.Geom.Hard Disk.Read.Error" or something like that, that as far as I can see now it's been resolved as it doesn't appear anymore after that; still, no success on booting the OS X partition.

Force Mount : using the terminal and the readOnly option, too; no success. All that mounts when I try to mount the whole disk is an "EFI" partition that contains a folder called "APPLE" with three more folders inside it: CACHES (one more folder, empty), EXTENSIONS (Firmware.scap) and FIRMWARE (MBP91_00D3_B0C_LOCKED.scap). What are these?

VRAM Reset : did nothing.

Volume Rebuilding : I've tried using both TechTool Pro and DiskWarrior to rebuild the partition, as both apps signaled damaged volume integrity and structure; neither app was able to rebuild the volume. TechTool Pro, in particular, stops at the very first verification step, "Journaled HFS Plus Volume". Does that mean the volume isn't recognised as HFS+ anymore? Does this have any significance?

OS X Combo Updates : The volume, being unmounted, doesn't show up so I can't install anything on that partition.

Data Recovery Tools : I tried different software and almost all of them extracted few files with very big sizes, all unreadable.

Cloning : I made two different .dmg images of my volume, using Disk Utility and Data Rescue 4, but I can't mount any of them as I get a "no mountable file systems" error.


This is my partition scheme; the "damaged" volume, on /dev/disk1, has the identifier disk1s2. As you can see, the same disk holds two more partitions, booting Windows 7 and Ubuntu Linux; both are working correctly, so this rules out the hard disk suddenly failing, I guess. Also, several checks of the drive show nothing amiss. The other disk (disk0), the SSD, is my boot drive and it's working fine.

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Crucial SSD             249.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS                         301.2 GB   disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
   4:       Microsoft Basic Data BOOTCAMP                165.8 GB   disk1s4
   5:           Linux Filesystem                         32.2 GB    disk1s5

fdisk /dev/disk1, instead, shows this:

Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE    0   0   2 - 1023 254  63 [         1 -  588785887] <Unknown ID>
 2: AB 1023 254  63 - 1023 254  63 [ 588785888 -    1269536] Darwin Boot 
*3: 07 1023 254  63 - 1023 254  63 [ 590055424 -  323803136] HPFS/QNX/AUX
 4: 83 1023 254  63 - 1023 254  63 [ 913858560 -   62914063] Linux files*

I'm at a loss of what to do next, I even wrote on the Apple Community forums and got no useful answers - I'd really appreciate some help on this. I realise that it's my partition scheme that probably generated the problem, as to make OS X, Windows and Linux all boot from the same disk I had to play a bit with the hybrid MBR - but still, isn't there any way to solve this?

If it helps somehow, both the Windows and Linux partition can go, maybe then I could force somehow the whole disk to be read as HFS+? Maybe then it would mount, at least? I don't know, these are just thoughts...

I read that sometimes it can be as simple as deleting some kext extensions that make the volume unbootable, but how would I go about doing that if the partition doesn't mount?

  • Installed both and logging in as root, I'm sending the credentials right now, thank you. – Red Flag Jul 8 '17 at 10:52
7

The Sierra installer messed up with the partition table of disk 1 - probably confused by the custom triple-boot setup and the hybrid MBR on disk1.

Disk1s2 is encrypted with FileVault and got the wrong partition type in the upgrade process somehow.

The partition type of disk1s2 is 48465300-0000-11AA-AA11-00306543ECAC but has to be 53746F72-6167-11AA-AA11-00306543ECAC.


In a TeamViewer session the following was done:

  • Install wxHexEditor onto "Crucial SSD " to be able to examine the content of disk1
  • Enable the root user
  • login as root
  • examine disk1s2's raw content with wxHexEditor. The type of a volume can be detected by having a closer look at the volume headers and other file system structures (which requires some expertise and/or wikipedia though - examples: HFS+, NTFS).

After removing partition disk1s2 with gpt and re-adding it with the proper type the volume is mountable again:

diskutil list #get all disks and partitions
gpt -r show disk1 #get the partition map of disk1
gpt remove -i 2 disk1
gpt add -i 2 -b 409640 -s 588376248† -t 53746F72-6167-11AA-AA11-00306543ECAC disk1
diskutil verifyDisk disk1

and after unlocking the FileVault volume

diskutil verifyVolume disk2 

†: example size

  • The problem was resolved. Once I booted into the OS X partition Sierra kept installing, then the Mac restarted and everything is now working perfectly. I can't express how happy I am, thank you very, very much. – Red Flag Jul 8 '17 at 12:01
  • @Izare OK...;-) & don't forget to disable root/uninstall wxhexeditor and Teamviewer... – klanomath Jul 8 '17 at 12:02
  • Will do...! :)) – Red Flag Jul 8 '17 at 12:07
  • 5
    +1 Great job klanomath - we're so fortunate to have you around here! :) @Izare, can I suggest you take this experience as a warning and ensure you have a backup regime in place (e.g. Time Machine, Carbon Copy Cloner, SuperDuper!, etc). Regardless of what you opt for, none of these are any good unless you actually use them. My apologies if it sounds like I'm preaching, but when you see as many people lose data as I have, well, you get the idea! :) – Monomeeth Jul 8 '17 at 12:26
  • 2
    You are completely right, @Monomeeth , and it's not preaching when you're right ;) I'm making a backup right now, if something like this ever happens again at least I'll be covered. Hopefully, in the meantime, I will have learned how to resolve situations like this, as klanomath did. ;) – Red Flag Jul 8 '17 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .