2

Using this tip from basic Google Search I was able to move the Dock to the right side:

enter image description here

The Dock does show only on the right side now. However it also displays (auto-unhides) when the mouse/cursor travels to the bottom of the screen.

It is distracting when interacting with full length windows. Can that behavior be disabled? I am on Sierra.

1

If you get unexpected behaviour after manually moving or adjusting the Dock, you can try restarting the Dock.

Open your Terminal (Applications > Other > Terminal or search for Terminal in Spotlight)

Type killall Dock after the prompt and enter.

Your Dock should restart with the expected behaviour. You can verify your settings in the System Preferences > Dock

Edit: It May be necessary to reset the Dock to factory settings then customize as needed. Some have experienced various dock bugs in Sierra.

  1. Open the Terminal
  2. Type (or copy and paste) defaults delete com.apple.dock; killall Dock
  3. Hit return
  • killall dock did not find any processes. Instead killall Dock did .. including Application Switcher. I have no idea how to restart those without rebooting. – javadba Jul 7 '17 at 18:19
  • It should restart on it's own after a few seconds. You'll notice in my answer that it is Dock with a Capital 'D'. Cheers – bjbk Jul 7 '17 at 18:20
  • Also, just for the record, please update your question with the version of macOS you are using. – bjbk Jul 7 '17 at 18:22
  • OK I missed that were in caps. The Dock did not restart .. after ten minutes now. – javadba Jul 7 '17 at 18:27
  • That seems to indicate that you have a more serious issue than normal. If a reboot does not fix the issue someone with a bit more process know-how may have further answers. – bjbk Jul 7 '17 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .