2

Whenever I start my MacBook (mid 2009, running OS X El Capitan 10.11.6), like any normal day, I click on my main account and log in.

Today, when I tried typing in my password, it let me in as usual but I get nothing but a black screen with the spinning beachball cursor. However, I can log in to my other account perfectly fine.

I've tried booting into safe mode and logging in but it just gives me the same result. I've also run First Aid on the disk, but that didn't resolve the issue either.

How can I troubleshoot this further?

  • Have you tried checking the logs from the other account? This is obviously something with the user account profile that's gone bad. Could be startup item, launchagent, launchdaemon or a preference for a finder function – John Keates Jul 8 '17 at 1:22
1

Removing the user/library/preferences could help, however, if you still have the same issue and booting in safe mode has not solved the problem, means that the user is damaged.

so try removing user/library/caches

if you still have the problem, the fastest solutions are next:

  1. restored a time machine backup to a date where issue does not exist if you have one.

  2. create a new user as administrator, sign into this new user and from finder transfer the content from the old user to the new one.

note: in this step you tested that preferences were not the caused of the problem, so moving the content of this folder from the old to the new one will bring you all the settings into the new account. Also note that apps are open from all users, so you will not have to install any app either. the only thing you would have to do is to set up the mail accounts in mail app from the new user.

0

You may have a login item on the account that is hanging for some reason. Try holding down the shift key when you log in to the account and seeing if you can get it. If so, go to the accounts preferences and take a look at the login items for that account and see if you see something you don't recognize or that's new and try removing it from the list.

  • Failing that I would move the contents of the "~/[USER]/Library/preferences" folder to the desktop and reboot. It may also be a damaged preference file. – Steve Chambers Jul 7 '17 at 13:09
  • When logging in while holding shift it still brings me to blackscreen, cant do anything just a cursor. – Ineedhelp Jul 7 '17 at 13:13
  • @Ineedhelp I would then follow the advice above from Steve Chambers and see if that helps, you should be able to do that from the terminal in the account you can log into, as long as that account is an administrator. – moneyt Jul 7 '17 at 13:15
0

Try this method:

  1. Turn off your Mac and connect it to the MagSafe adapter and a wall outlet.

  2. Hold down Shift + Control + Option + Power keys simultaneously for a few seconds.

  3. Release all the keys at the same time, then start your Mac as usual.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .