5

When I initially got my MacBook, I connected my external monitor and it worked fine. Last night I disconnected it and when I connected them back together, the resolution on the external monitor was changed. The overall display is now magnified (for example as I'm writing this I have to scroll down to see this).

I tried to change the resolution settings in Preferences but this didn't help to change it back. So how can I set the resolution of the external monitor back to a sane state?

  • Unplugging the monitor and plugging it back in fixed a similar issue I was having with Lion. – Nathan Greenstein Jan 22 '12 at 4:49
  • I have the exact same problem! I now set my external monitor resolution to 1440x900 (as always did) but it's definitely at a lower resolution. I tried turning it on and off, selecting diferent resolutions, plug-unplug, etc to no avail. Any ideas? – iign Feb 10 '12 at 13:16
1

Maybe you accidentally magnified your screen using Universal Access's screen Zoom, it can survive display detects with out zooming back out. And it can be accidentially triggered via holding down the key or some customizable key and then scrolling up or down with your mouse or track pad.

  1. Look in System Preferences under the "Univeral Access" section.

  2. Once there click on the "Seeing" tab. Is "Zoom:" on? If yes then continue.

  3. Press + + - to zoom out.

0

In System Preferences, select Displays. On each running display (i.e. both on the external monitor and the MacBook itself, should it be open) a list of supported resolutions will be displayed. Click "Detect Displays" on the dialog shown on the external monitor. This should make the system recognize the kind of display and the supported resolutions. You should then be able to change between these without problem.

  • 1
    I have the same issue and this didn't resolve the problem. – iign Feb 10 '12 at 13:17
0

I just had this problem on High Sierra 10.13.4 on my 2015 Retina Macbook. Solution was to reset the SMC (as per idownloadblog):

  1. Power off computer
  2. Press and hold altogether left Shift Ctrl Alt and the power button for a couple of seconds.
  3. Wait nervously for what feels like ages.
  4. Press the power button. Probably nothing happens.
  5. Wait even longer and avoid biting fingernails
  6. Press the power button.
  7. Hear startup chime with great relief.
  8. When computer comes back up the display may still be zoomed, but if you go to the display preferences you should now be able to find a resolution that works (previously, for me, the correct display resolution was not available for the external display).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .