5

I have to connect to Cisco AnyConnect VPN from my Mac for work. Whenever I do, I lose the Internet.

My routing table before connecting;

Routing tables

Internet:
Destination        Gateway            Flags        Refs      Use   Netif Expire
default            10.0.2.1           UGSc           26        0     en0
10.0.2/24          link#4             UCS             5        0     en0
10.0.2.1/32        link#4             UCS             1        0     en0
10.0.2.1           64:a5:c3:61:2a:ba  UHLWIir        33      486     en0   1146
10.0.2.2           d0:7e:35:d4:ef:68  UHLWI           0        9     en0   1200
10.0.2.4           c4:b3:1:c9:7f:89   UHLWI           0        0     en0    782
10.0.2.10          18:65:90:cf:15:17  UHLWI           0        0     en0   1164
10.0.2.14          f4:5c:89:94:c7:45  UHLWI           0        0     en0    347
10.0.2.17          e0:94:67:2d:81:2e  UHLWI           0       40     en0   1146
10.0.2.26/32       link#4             UCS             0        0     en0
127                127.0.0.1          UCS             0        0     lo0
127.0.0.1          127.0.0.1          UH              1    36418     lo0
224.0.0/4          link#4             UmCS            2        0     en0
224.0.0.251        1:0:5e:0:0:fb      UHmLWI          0        0     en0
239.255.255.250    1:0:5e:7f:ff:fa    UHmLWI          0       82     en0
255.255.255.255/32 link#4             UCS             0        0     en0

Internet6:
Destination                             Gateway                         Flags         Netif Expire
default                                 fe80::%utun0                    UGcI          utun0
::1                                     ::1                             UHL             lo0
fe80::%lo0/64                           fe80::1%lo0                     UcI             lo0
fe80::1%lo0                             link#1                          UHLI            lo0
fe80::%en0/64                           link#4                          UCI             en0
fe80::1411:5e1:f2bf:a3ec%en0            18:65:90:d0:6a:11               UHLI            lo0
fe80::%awdl0/64                         link#8                          UCSI          awdl0
fe80::207a:82ff:febb:4907%awdl0         22:7a:82:bb:49:7                UHLI            lo0
fe80::50c8:6fe8:9656:1a31%utun0         link#10                         UHLI            lo0
ff01::%lo0/32                           ::1                             UmCI            lo0
ff01::%en0/32                           link#4                          UmCI            en0
ff01::%awdl0/32                         link#8                          UmCSI         awdl0
ff02::%lo0/32                           ::1                             UmCI            lo0
ff02::%en0/32                           link#4                          UmCI            en0
ff02::%awdl0/32                         link#8                          UmCI          awdl0

My Routing table after connecting;

Routing tables

Internet:
Destination        Gateway            Flags        Refs      Use   Netif Expire
default            link#11            UCS            46        0   utun1
default            10.0.1.1           UGScI           9        0     en0
10.0.1/24          link#11            UCS             0        0   utun1
.
.
.
.
.
10.79.115.36/32    127.0.0.1          UGSc            0        0     lo0
239.255.255.250    1:0:5e:7f:ff:fa    UHmLWI          0        4     en0
255.255.255.255/32 link#11            UCS             0        0   utun1
255.255.255.255/32 link#4             UCSI            0        0     en0

Internet6:
Destination                             Gateway                         Flags         Netif Expire
default                                 link#11                         UGCS          utun1
default                                 fe80::%utun0                    UGcI          utun0
::1                                     ::1                             UHL             lo0
.
.
.
.
ff02::%lo0/32                           ::1                             UmCI            lo0
ff02::%en0/32                           link#4                          UmCI            en0
ff02::%awdl0/32                         link#8                          UmCI          awdl0

So the default gateway changed from en0 to utun1

How can I configure my routing table so that I can use internet too while I am connected to the VPN?

4

Your VPN software is enforcing this change and breaking your local access intentionally. You would need either :

  1. The ASA/vpn endpoint to allow split tunneling
  2. A modified vpn client that allowed you to disregard the request from the ASA to not allow split tunneling.

On the Asa side, the vpn administrator would need to follow a guide like this to allow you the flexibility to keep local connections alive once you bring up the vpn.

Yours is a long standing sore point for uses of VPN software.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .