2

For various reasons that aren't important, whenever my MacBook reboots, Safari extensions are disabled. I can manually go into the Develop menu, and uncheck Disable Extensions, and that work just fine, but its annoying and an extra step that I have to remember.

I wrote a simple script that checks the output of defaults read com.apple.Safari ExtensionsEnabled

and if it is 0, runs defaults write com.apple.safari ExtensionsEnabled 1

This all works and it does indeed set that parameter to 1, but Safari does not actually enable my extensions, Develop - Disable Extensions remains checked, and my extension icons don't appear. Restarting Safari after running it does not help either.

So is there a cache I need to clear somewhere for Safari to re-read the plist and enable extensions?

I've also considered writing an applescript that would just simulate the human interaction, but the laptop is locked down and I can't add it to accessibilities due to no permissions, so that's a no-go.

You must log in to answer this question.

Browse other questions tagged .