1

A coworker has Apple in a mostly Windows environment, she sometimes receives email that has Icelandic letters in the subject and sometimes (not always) they get decoded wrongly. I have tried to fiddle around with fonts with no luck in that. I see from the mail headings that the mail gets sent using the ISO-8859-1 encoding but can't find a solution to the problem.

Here are the headings from two mails, the former shows the Icelandic letter 'ð' as 'š' but the latter heading shows it correctly (note, this is only in the subject, the main text is fine).

Return-Path: <user1@bla.com>
Delivered-To: user2@bla.com
Received: from user1 (unknown [IP address])
    (Authenticated sender: user1@bla.com)
    by outside.mailprovider.com (Postfix) with ESMTPA id 00DA712006F;
    Wed, 31 May 2017 13:11:33 +0000 (GMT)
From: =?iso-8859-1?B?S3Jpc3TtbiDTc2sgSvNuYXNk83R0aXI=?= <user1@bla.com>
To: "'User3'" <user3@bla.com>,
    <user2@bla.com>,
    <user4@bla.com>,
    <user5@bla.com>
Subject: =?iso-8859-1?Q?fundarger=F0_89._MNN_fundar?=
Date: Wed, 31 May 2017 13:11:33 -0000
Message-ID: <003601d2da0f$6d54bc00$47fe3400$@uw.is>
MIME-Version: 1.0
Content-Type: multipart/mixed;
    boundary="----=_NextPart_000_0037_01D2DA0F.6D5642A0"
X-Mailer: Microsoft Outlook 14.0
Thread-Index: AdLaD0dkN4N8uPchRNy8u4QHBCJiLQ==
Content-Language: is

And the second one that shows it correctly.

Return-Path: <user3@bla.com>
Delivered-To: user2@bla.com
Received: from [internal ip address] (unknown [external ip address])
    (using TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits))
    (No client certificate requested)
    (Authenticated sender: user3@bla.com)
    by outside.mailprovider.com (Postfix) with ESMTPSA id 89CEC12006F;
    Wed, 31 May 2017 13:29:57 +0000 (GMT)
From: User3 <user3@bla.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_D5239118-AC5C-47BC-811F-EB55A38501AD"
Message-Id: <AE509899-9943-424A-B2E4-9183507BB06B@uw.is>
Mime-Version: 1.0 (Mac OS X Mail 7.3 \(1878.6\))
Subject: =?iso-8859-1?Q?Re=3A_fundarger=F0_89=2E_MNN_fundar_?=
Date: Wed, 31 May 2017 13:29:56 +0000
References: <003601d2da0f$6d54bc00$47fe3400$@uw.is>
To: =?iso-8859-1?Q?User1 <user1@bla.com>,
 User2 <user2@bla.com>,
 =?iso-8859-1?Q?User4 <user4@bla.com>,
 =?iso-8859-1?Q?User5 <User5@bla.com>
In-Reply-To: <003601d2da0f$6d54bc00$47fe3400$@uw.is>
X-Mailer: Apple Mail (2.1878.6)

The subject of these mails should be the same, reading "fundargerð 89. MNN fundar". As you perhaps can see then there is a slight difference, the former has a dot after 89 but the second encodes the dot as "=2E" and the former ends as "fundar?=" while the second ends as "fundar_?=". I don't see any difference in the offending character, namely "=F0" at the end of "fundarger".

Any hints on what is going on is well appreciated.

  • 1
    For =F0 to be interpreted as š, it would seem to require that the subject line be read as if it were encoded as ISO-8859-13. See en.wikipedia.org/wiki/ISO/IEC_8859#Table No idea why that would happen. – Tom Gewecke Jul 4 '17 at 11:41
  • @TomGewecke yeah, specially since the encoding is specified as ISO-8859-1 in the beginning of the subject. Does Apple Mail perhaps not use that information to decode the text in the subject line? – ojs Jul 4 '17 at 13:58
  • I've never seen it botch something like this. Do you get the same result if you use web mail instead of the Mail app? – Tom Gewecke Jul 4 '17 at 14:13

You must log in to answer this question.

Browse other questions tagged .