1

I have an iMac here which does not wake from sleep when I press keyboard buttons or click the mouse button. Also while in sleep the iMac is not charging my iPhone via USB. So it seems that the USB ports are completely disabled.

Strange thing is, that this "deep" sleep mode is active after a few hours "going to sleep". Within this time waking via USB works.

I booted this system (on SSD) a while ago on a MacBook Pro – it took a while to initialize and boot – maybe there are some power management tools get activated from a MacBook system?

Any idea of internal settings that turn completely off the USB ports after a time?

Can someone please check these settings on his iMac?

pmset -g

# typing "pmset -g" in Terminal gives me this result:


System-wide power settings:
Currently in use:
standby                1
Sleep On Power Button  1
womp                   0
halfdim                1
hibernatefile          /var/vm/sleepimage
powernap               0
autorestart            0
networkoversleep       0
disksleep              0
sleep                  10 (sleep prevented by useractivityd)
autopoweroffdelay      28800 <- maybe this setting?
hibernatemode          0
autopoweroff           1
ttyskeepawake          1
displaysleep           10
standbydelay           10800 <- maybe this setting?

Maybe autopoweroffdelay or standbydelay parameter is responsible for this "deep" sleep?

1

I'm using Mac Mini with Apple Thunderbolt display. I'm currently in OS X El Capitan 10.11.6. My parameters are the following:

Active Profiles:
AC Power               -1*

Currently in use:
standby                 0
Sleep On Power Button   1
womp                    0
autorestart             0
hibernatefile           /var/vm/sleepimage
powernap                0
networkoversleep        0
disksleep               0
sleep                   0 (sleep prevented by iTunes, coreaudiod)
autopoweroffdelay       14400
hibernatemode           0
autopoweroff            1
ttyskeepawake           1
displaysleep            0
standbydelay            4200

I recommend you to set up all you Energy Saver parameters like this:

enter image description here

And you can put your display to sleep via Mission ControlHot Corners:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .