0

I am trying to dd an ISO to a USB so I can install Linux on another computer, but the USB changes from any partition table (GPM or MBR) to APM when it finishes.

I'm using the following command:

sudo dd if=[path of iso] of=/dev/disk2

The command "diskutil list" successfully shows the usb is /dev/disk2 and Disk Utility shows the partition table before has changed to APM.

I've worked with dd and Disk Utility several times in the past and have never until now had this problem. I believe it changed after I upgraded from OS X to macOS.

APM is not able to be used on this computer so the ISO on the USB can't be read. Help?

  • You are probably dd'ing a hybrid disc. It contains an ISO prim vol descriptor as well as an APM. Please add a link to the iso (Ubuntu?)! – klanomath Jul 4 '17 at 0:20
  • It doesn't matter what the partition table of the USB is, just make sure it's not mounted prior to using dd. The partition table of the USB will be whatever the ISO image is, as it's whats being written to the USB drive. – user3439894 Jul 4 '17 at 0:21
  • @klanomath I'm using the standard fedora 25 workstation and tried the same with qubes. I'm going to try the same with debian just for a test later tonight – Noob101 Jul 4 '17 at 0:26
  • @user3439894 it does when there aren't software drivers to work with APM and MBR is needed – Noob101 Jul 4 '17 at 0:26
  • @Noob101, You're missing the point, the USB will be partitioned however the ISO Image is laid out. If it's layout it not compatible with the Hardware it going to be run from then you need to get an ISO Image that's compatible! – user3439894 Jul 4 '17 at 0:48
1

You're overwriting the disk device, not a partition on it, so yes, some chunk of the data from the ISO is going to overwrite the partition table on your USB device.

You don't provide enough details to determine anything else.

  • So then I just dd to the partition? and what information am I leaving out? – Noob101 Jul 5 '17 at 16:43
  • @Noob101 No, the ISO 9660 volume header has to be in the raw disk, not in a partition. An ISO 9660 disk has no partition table (unless it's some sort of hybrid format). – Gordon Davisson Jul 6 '17 at 21:30
  • @GordonDavisson Well I'm not using a partition. /dev/disk2 is the over arching device, not the device partition. So the question remains of why I get APM. If I was dding to something like /dev/disk2s1, then I would agree with you. – Noob101 Jul 6 '17 at 21:34
0

I was unable to resolve this issue on my macbook and used some else's mac instead. I have no idea why it works on theirs but not mine. Very mysterious...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .