2

Here's my iCloud settings:

icloud

As you can see, the Desktop and Documents Folders checkbox is unchecked.

Despite this, my Desktop and Documents folders have suddenly been renamed to "Desktop - Local" and "Documents - Local" respectively.

The only reason I can think of is this may be due to installing iOS 11 on my iPhone, but I'm not sure.

Can anyone suggest any other possible reasons?

2

This is caused by iCloud Drive. This is to distinguish it with the Desktop and Documents folders on your iCloud Drive, which are named "Documents — iCloud", even if you didn't setup iCloud Drive on your Mac.

The most probable cause, as found by the OP and me, is installing and running the new Files app on iOS 11.

enter image description here

  • Note that iCloud Drive already works on iOS 10.2, so it's probably not caused by iOS 11, but you might have turned this option on during the installation of it? – Glorfindel Jul 3 '17 at 5:48
  • It's already off as I've shown in my post. – user3306356 Jul 3 '17 at 5:48
  • Hmmm ... strange. Maybe it's something which is cached by Finder. But even if you turned it off on your Mac, the iCloud Drive folder still exists. – Glorfindel Jul 3 '17 at 5:50
  • I've never turned it on before. – user3306356 Jul 3 '17 at 5:51
  • iOS11 has a new program called "Files" which automatically creates a folder called Documents on your iCloud drive, this might be the culprit reversely turning on iCloud Documents and Desktop. – user3306356 Jul 3 '17 at 5:55
0

You’ve got two folders called Documents, one on iCloud Drive and the other one on your Home directory. It will says - Local or iCloud unless you deleted Documents folder on your iCloud Drive as it cannot be renamed. Best to create a new folder and move contents within Documents in iCloud Drive into new created folder labelled something different name other than Documents. Then you will see without - Local or iCloud.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .