2

My friend's iMac crashed. He took it to an Apple Store and they said the 1 TB HDD was failing. They got him to boot off an external and told him to go home back his stuff up and they can order and install the exact same Fusion Drive. As he was backing up, the drive dismounted and didn't show up again. We got a new SSD and swapped out the old 1TB seagate HDD. OS installation was successful.

My friend is a photographer and unfortunately he didn't use Time Machine or have any backup procedures in place. I connected the HDD to an external port through USB to the iMac. I ran the command,

diskutil coreStorage list 

enter image description here

Tried it in Recovery Mode as well and the drive was not listed.

What are my options for data recovery? I'm not sure if the drive has completely failed because Apple was able to give him access to the drive when it failed the first time.

The 128 GB SSD is there but not shown in target disk mode. Is this related to some config issued because of the way the Fusion Drive is mapped out. For example, if I were able to boot off the 128 GB SSD will I be able to read the 1 TB HDD. Or, is it possible for me to mount the HDD to my iMac and salvage the 100 GB of data needed.

You must log in to answer this question.

Browse other questions tagged .