0

I have a 2015 MacBook Pro. I recently moved and don't yet have a Wi-Fi router, so I have to use an ethernet cable. To do this I'm using a USB ethernet adapter.

When I plug it in Bootcamp automatically detects it and connects to the internet. However, when I switch over to macOS, it doesn't detect anything. I've tried to manually set it up, but even then it acts like nothing is there.

I don't understand why I can connect on one OS but not the other on the same machine.

How can I troubleshoot this?

  • This sounds like macOS could simply be missing a driver for the device, and so does not recognize when it's connected. Was the device specifically designed for use on a newer Mac circa the USB C hub and USB C 3.5mm jack adapter, or is this a generic/3rd party USB ETH adapter? – Alison E.E. Jul 2 '17 at 4:54
  • It's a third party adapter. Can the macOS only work with the Apple ethernet adapter? – Forkball Jul 2 '17 at 5:31
  • 1
    It should work fine, but you'll need a driver to get it working. Apple includes drivers for their own hardware, as well as generic devices that most people use (i.e. a non-Apple USB keyboard) in every copy of macOS. With something like a USB ETH adapter however, macOS probably wont include it. What brand and model is the adapter? Also, does it connect directly to the USB type C port, or is it a standard USB 2.0/3.0 connector? – Alison E.E. Jul 2 '17 at 6:00
1

If it's the standard Apple ethernet adapter, I've run into this problem on a couple of different MacBooks. There are a few different things you can try in this thread on Apple's message boards, but the one that usually works for me is this one:

  • in System Preferences > Network, create a new network location
  • delete all the network devices from the list on the left
  • re-add the ethernet adapter device
  • configure the rest of the new location as required, and use it instead of the one you were previously using

(Even with that working, I still have another annoying issue with the adapter: if I plug it in while the laptop is asleep, it's not detected when it wakes. Have never found a solution for that.)

0

It does this because there is a driver for whatever this adapter is in the one OS, but not in the other OS.

You would therefore install the missing driver on the OS where the adapter does not work.

  • It works. I just needed to wait for 10 mins, when Mac was installing driver behind the scene after first connect. Magically it worked after 10 mins. – ankitjaininfo Apr 24 at 9:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .