1

When macOS Sierra came out I tried to upgrade, but my monitor just showed nothing. When I used CMD+R and restarted from there, I could access my Mac. Eventually I had a technician reinstall El Capitan, because no advice I read online helped.

Now I've tried upgrading to macOS Sierra again (using the macOS Sierra button that's been in my Launchpad for about the past nine months) and this time it was worse. I can access CMD+R, but restarting from there has no effect.

I use a Philips monitor on which the power button blinks when it is asleep. After upgrading to macOS Sierra, it had the same effect - my monitor seems to be asleep while my Mac is running.

I used a backup to revert back to El Capitan. macOS Sierra has brought nothing but troubles and now even El Capitan seems a bit slower than before. I hope nothing was corrupted during the Sierra upgrade and backup restore.

Does anyone have any ideas on why this could be happening? Is it due to my monitor not being Apple hardware? Or is it because Sierra just isn't working with my Mac Mini?

I use Mac Mini Late 2014 and Philips 223V LED monitor

  • Welcome to Ask Different! :) Considering the nature of your question, can I suggest you edit the question to include the exact model of your Mac mini and its specifications? It'd also be good to know the exact model of your Philips monitor. – Monomeeth Jul 1 '17 at 13:16
  • @Monomeeth Hello! Added the specifications. – Samjaka Jul 1 '17 at 13:24
  • Are you are using display port for connection? Please connect your monitor with HDMI and try again. – dante12 Jul 1 '17 at 21:37

You must log in to answer this question.

Browse other questions tagged .