5

I'm trying to reformat a Mac that was handed to me by an employee after being wiped, and I'm starting to think they did too good a job.

At boot, you see the blinking folder + ? icon, indicating no bootable partition found:

Loading the recovery partition (after resetting NVRAM), I tried all this on both the Internet Recovery partition which was Snow Leopard and a macOS Sierra media installer via USB.

First, Disk Utility didn't show the drive: enter image description here

From there, I tried diskutil list enter image description here

Which didn't see the drive. Then I tried df -h enter image description here

Failing anything else, I restarted and held 'd' to get into Apple Hardware Test: enter image description here

Running the test reported "no problems found". The Hardware Profile tab did not report a hard disk, but I'm not sure it ever does (I don't have any other pre-2013 Macs to test on).

So, I'm left without many options. I can't boot into single user mode, because there's not an install into which I can boot. I don't know how to reformat/repartition a physical drive that's not reported by diskutil or df. And it's clearly not something I can fix with setting up a logical volume in CoreStorage (on the Sierra recovery image, that is) if the underlying physical disks are absent.

Can anything else be done, or is this all pointing to the SSD being dead?

  • Just to cover it - you're sure there is a drive in there and the employee didn't take it out and keep it, or something else? Are you able to test if the drive is "seen" by another Mac? Perhaps the employee removed it to wipe it and didn't seat a cable correctly. – vcsjones Jun 30 '17 at 21:44
  • 2
    Just confirming you wouldn't expect to see a hard drive listed in the Hardware Profile tab. :) Also, all 2009 MBP shipped with FireWire, so it may be worth trying to boot the MBP in Target Disk Mode and connecting it to another Mac via FireWire to see whether a drive is recognised. – Monomeeth Jul 1 '17 at 0:12
  • @Monomeeth - My bad, it's a 2012 retina MBP. I stupidly said 2009 because the recovery drive had Mountain Lion and I mistook it for Snow Leopard. No FW, just TB – Justin Searls Jul 1 '17 at 1:00
  • Ah, ok. Well these MBPs do support USB target disk mode, although this requires certain USB-C cables, so this may not be an easy option for you. For more info you can refer to my earlier link. Also, it may be worth considering the possibility raised by @vcsjones as this wouldn't take long to establish as long as you have a P5 Pentalobe screwdriver handy. Fyi, the SSD should be located under the trackpad. – Monomeeth Jul 1 '17 at 1:31
0

The answer was that the SSD died. Replacing the SSD fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .