0

I'm running a Fedora (also a Ubuntu) guest in VMWare Fusion Pro 8.5 on macOS Sierra. I've got a problem that's been bugging me for a long time: the keyboard keys don't map across correctly from the host to the guest. I've got the UK, Macintosh layout set in the guests, and the keyboard map shows the correct layout. But, as an example, when I need to type ~, I actually have to type ±, etc. Yet the @ and " keys map correctly.

I've read lots of advice about using the Keyboard and Mouse settings in VMWare Fusion to map the keys correctly, but as far as I can tell, these options only relate to shortcuts (am I missing something)?

Also, given that Fusion is designed for the Mac, how is it that it can't detect my MBP's keyboard layout and correctly map that to a Mac layout? Is it just me, or is that crazy?

1

I've been running a Linux guest on my iMac VMware Fusion Hypervisor for years and have been logging in via ssh to avoid this. Only recently set it up for Gnome. I found that configuring gnome for an Apple keyboard solved most of the issues with tilde etc. The one key which I did have problems with was the hash '#' key which for some reason either works via SHIFT-.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .