1

I had Thunderbird configured with an iCloud (me) email account and it worked fine until about two weeks ago. When I tried to send a message, it asked me for the server password. When I entered it, I got a message saying the login or password was wrong. I also had this same problem on another machine with another account. I was able to add and use a Gmail account without any problems.

My setting are: Incoming

Protocol: IMAP
Server: imap.mail.me.com
Port: 993
SSL: SSL/TLS
Authentication: Normal password

Outgoing

Protocol: SMTP
Server: smtp.mail.me.com
Port: 587
SSL: STARTTLS
Authentication: Normal password

I got the settings from How can I configure iCloud mail in Mozilla Thunderbird?

I am able to login to both iCloud accounts through a browser.

  • you have an old @me.com mail right ? – Lars Nielsen Jun 30 '17 at 6:25
  • One of the machines is me.com and the other is icloud.com – Jim Tshr Jun 30 '17 at 14:43
3

Starting June 15, 2017, Apple requires two-factor authentication on all iCloud accounts that access their accounts non-natively. Apple’s third-party email client setup instructions have since been updated accordingly.

Native iCloud access is limited to System Preferences on macOS, the Settings app on iOS, and iCloud for Windows. All other apps, including Thunderbird and Outlook, require an app-specific password.

To enable two-factor authentication:

  • On an iOS device open SettingsPassword & Security and tap Turn On Two-Factor Authentication.
  • On your Mac open System PreferencesiCloudAccount DetailsSecurity and click Turn On Two-Factor Authentication….

Then, login at https://id.apple.com/ and under SecurityApp-Specific Passwords, click Generate Password…. Enter that password into Thunderbird.

This was done to keep third-party apps from getting access to your iCloud password, thus reducing the likelihood of iCloud account breaches.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .