6

I'm completely flustered by not being able to use the single key shortcuts in Chrome's debugger

  • F8 = play
  • F10 = step
  • etc.

I have to reach over to the laptop and press and hold the Fn key and then, with my other hand, I can use the F keys on my standard keyboard.

I tried changing the keyboard settings to force the Touch Bar to display function keys for Chrome.app but this did not solve the problem as it only solved it for the built-in keyboard, not my external keyboard.

I have Karabiner but it's limited in my version (10.12.x Sierra). I also can't do a macro of one key to multiple.

Is there any way for me to achieve this?

2

In karabiner-elements Preferences, in the Function Keys tab, there is an option at the bottom, "Use all F-keys as standard function keys".

Karabiner-Elements will also allow you to bind a key that exists on your external keyboard to Fn, like Caps Lock or PrtSc under the Simple Modifications tab.

You can combine these two, so you can still adjust brightness with your F-keys by holding down the combination of Fn+F1/Fn+F2, where Fn is whatever key you mapped it to.

  • Yes, you also have to select the device, I have only tried it with my external keyboard and it did finally work. Since I have posted this question I have gone thru a few update son elements so I suspect this was a bug that now has been fixed or maybe I did not select the correct target device which in my case "no product (no manufacture name)" which is completely confusing – LMS5400 Oct 24 '17 at 17:34
3

You can check the following checkbox via System Preferences > Keyboard (default tab):

enter image description here

  • i'm using elements, this should work for the non-elements app – LMS5400 Oct 24 '17 at 17:33
  • True, I had the same issue as you (but without elements) and google sent me to this page, that's why I wanted to share my solution. – Ludder Oct 25 '17 at 7:54
  • Where did it go? :( i.stack.imgur.com/Cr3h7.png I'm on macOS 10.13.3 (17D47). Is there another setting you need to check to get this option to appear? My external keyboard is hooked up and working. – squarecandy Feb 12 '18 at 0:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .