10

I recently got an older MacBook Pro that has an optical drive. Every time I insert a CD, iTunes will always respond in some way.

I have already tried changing the setting in iTunes > Preferences > General, but I don't see the option I want.

How do I get this Mac to absolutely do nothing when I insert a CD?

  • Disconnect its cable... ;) – Adam Davis Jun 28 '17 at 13:44
13

You can do this in your Mac's system preferences:

  1. Go to Apple > System Preferences > CDs & DVDs
  2. You'll see a menu for When you insert a music CD
  3. Change that menu from "Open iTunes" to "Ignore".

Notes:

  • You may also want to check the options for Blank CD and Blank DVD as they also include built-in options to open iTunes.
  • The other menus also provide the ability to run a script, so if you got the MacBook from someone and you're using their old account, these may be worth checking as well in case they're launching iTunes or another application.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .