0

When I text people from my iPhone, people receive the texts from my cell number. However, when I text people from my laptop, it opens a new contact on their phones from "myname"@icloud.com. I can't seem to fix this annoying issue.

2

If you open Messages, then go to Messages -> Preferences -> Accounts -> "myname"@icloud.com, you can see the option to select where new conversations are started from. For me it lists my iCloud email, my personal email (which is my iCloud login), and my cell number. Choose your cell number from this list and everything should be OK.

0

Also in the Messages -> Preferences -> Accounts -> "myname"@icloud.com, you will see a Checkbox "Enable this account". If you never want to use this account for messages, just deselect the Checkbox and the account will be deactivated.

0

What's happening is your computer is using your signed-in Apple account to send iMessages rather than your phone number (iMessages can be sent using your Apple account and an internet connection without a phone number). Under Messages -> Preferences -> Accounts, you can disable your iCloud email account for iMessages.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .