0

Not even sure what question to ask, other than "what should I do next?"

UPDATE: Reinstall didn't work! (Details at end)

MacBook Pro (MBP) 2012 (approx.) with one-terabyte SSD and 10.12.4 was working fairly well, until suddenly I can't log in. Boot-up appears normal to the login screen. But then, whichever account I select goes to the desktop background and nothing else. No dock, no icons, no menu bar. Sometimes a spinning beachball, sometimes not. When the beachball isn't there, the Finder shortcut to log out makes it appear (but not logout). Three different accounts. Guest account is not enabled. "Other" is available but since I am not on a network, I can only type in one of the local accounts (which did the same thing as selecting by mouse).

Boot the recovery partition and select Disk Utility. Select the disk and first aid. "Seems to be OK". Select the volume within the SSD and try that. "Could not be unmounted for repair."

This started not long after I left a college. I did not install any of their software, but I did automount two directories from their Windows network. However, the MBP worked for more than two months after I got off their LAN, and I think I removed the automount lines before this failure.

Unfortunately, I had worked about a week without backups when the failure occurred. The MBP is under warranty, but the SSD was transferred from an older machine.

UPDATE: Bought this machine because the old one's CD died, it's WiFi was flaky, and it had dents on the case. But it was bootable. Put this SSD back in the old one, and now it won't boot. Just three beeps and nothing on screen.

Put everything back and booted into Recovery again. Disk Utility still can't unmount; says it is in use. Terminal, lsof shows notifyd is using it. Kill notifyd and it restarts but doesn't re-open the SSD. But Disk Util GUI still can't unmount.

Terminal, diskutil unmount fails because the kernel (PID 0) objects. diskutil unmount force works. GUI first aid claims to have changed some things. Reboot; still can't log in. Login screen shows four accounts, but I checked /Volumes/ISSD/Users while in recovery, and one of them does not have a home directory. That one, I don't remember password, but the others can't log in either.

None of the users are in /Volumes/ISSD/etc/passed, and the recovery partition no longer has the ability to fix user accounts.

UPDATE: I bought another external disk and used the recovery partitions terminal to copy files I wanted into it. Then I reinstalled MacOS, but after it rebooted, instead of going into setup, it looks no different than before! All the accounts are still there and can't log in!

  • Can you transplant the SSD into another Mac and try Disk Utility there? 2011-2012 MacBook Pros are known for their subpar SATA cables. – user24601 Jun 26 '17 at 14:35
  • This is a refurb, and the Apple shop specifically mentioned that issue when I took the old one in, but it's worth a try. I still have the old one. (Although I think I already tried it. It's a pain, since I have to use a tiny Phillips, a Torx, and a three-lobe to make the swap. – WGroleau Jun 26 '17 at 15:00
  • @WGroleau the 2012 Macbook is old, I have one, it works very slow, so I put it away. My suggestion is to buy a new MBP. – aircraft Jun 26 '17 at 15:25
  • I bought this refurb this year from Apple. That's why I said it is still under warranty. The old one was bought used, but the SSD was added new less than three years ago. I'd like to upgrade, but I hesitate at the cost of an SSD this size. – WGroleau Jun 26 '17 at 15:28
  • @user24601: On second thought, the recover partition is on the disk. It would be same software, same hardware, so expecting anything different would be irrational. – WGroleau Jun 26 '17 at 15:47

You must log in to answer this question.

Browse other questions tagged .