10

I received my brand new iMac today. During installation/startup, I was surprised to find that I could not log in to iCloud. I skipped, figuring it was a minor glitch and I would do it after setting up the new computer account.

I have discovered that I cannot log on to anything on this brand new computer. I get a different error phrasing with each app, but they all basically state that "An unknown error occurred." I contacted Apple, got bumped to level 2 support, and now we are working with engineering to diagnose. I thought I would see if anyone has any other ideas or similar experiences.

Here is what I know:

  1. This started from the moment I turned the computer on for the first time, where you initially are supposed to login to iCloud.
  2. I cannot login to iCloud, iTunes, or the App Store from this iMac.
  3. When I login, each app gives a slightly different error message but they are all consistent.
  4. When I login, I get a spinning "wait" icon that lasts about 20-30 seconds, then a message comes up.
    • Apple app store and iTunes store says "an unknown error occurred".
    • iCloud says "Verification failed. An unknown error occurred."
  5. I can login to both icloud.com and appleid.apple.com on the new iMac without a problem.
  6. I can login to all of these apps on my Macbook Pro without a problem.
  7. I can login to all of these apps on my iPad 2 and iPhone 6 without a problem.
  8. My wife cannot login to her own app accounts on this new iMac computer.
  9. I tried booting into safe mode, still could not login to anything.
  10. Apple support had me make a secondary "test" account on the new iMac, still could not log in from there.
  11. I have tried wired ethernet, home WiFi, and AT&T cellular WiFi via iPhone personal hotspot -- same problems.
  12. I reset the computer, and also reset the router and modem, no dice.
  13. We ran Disk Utility, no problems.
  14. I tried changing the computer date to one day ahead, this did not help.
  15. We reinstalled MacOS, that did not work.

Any help or insight would be tremendously appreciated. Fair warning, I have a duplicate post on the Apple forums just to broaden my net, sorry if that is inappropriate in any way.

  • 1
    You said that you tried wired, home WiFi, and a personal hotpot, but you never said how you verified that you were connected. Are you able to browse the web? Also, you said it gave you an error message - what was that error message? – Allan Jun 24 '17 at 2:59
  • Yep, I can browse the web. The only thing I cannot do on this computer is login to anything requiring an Apple ID. See point #4 in my original post for the error messages I get from each app. – Ben Stull Jun 24 '17 at 9:41
  • There should be nothing preventing you from logging in especially after you reinstall macOS. If I had to guess, I would bet that that particular machine was an "open box item" where the previous owner set it up and signed into iCloud with it only to return it but not deauthorize it. – Allan Jun 24 '17 at 11:05
  • 2
    Maybe try to look at the logs when trying to log in in the App Store app. In Console.app, type process:store and hit Enter. Then try hit the Clear button in Console.app just before trying to log in in App Store, and see if any of the log that appears in Console.app would help diagnosing the problem. – Guillaume Boudreau Jun 28 '17 at 17:18
  • 1
    When you reinstalled macOS did you use disk utility to erase the drive first? If not you should backup and do this. – unknowndomain Feb 24 '18 at 0:07
1

I've had this a number of times after installing a new copy of OSX, sometimes I was able to link to iCloud etc subsequent to install but ALWAYS with other problems that came up later, it never cleaned everything up to be working 100%. I also spent a lot of time and effort with second level AppleCare to no avail.

The ONLY successful solution I found, unfortunately, was to clean install over and over until it went through successfully. This often had to wait a number of days.

Personally, I suspect network issues which Apple were unable to pin down.

Eventually, all the computers I had issues with (which included a brand new iMac) worked and have worked ever since - about 2 years (Plus one 6 months ago).

Good Luck!

Paul.

1

You just need to remove the device on iCloud. You can do it with your iPhone in the settings -> profile -> devices list -> macbook -> remove

0

I agree with one of the commenters. Do a netrestore, but be sure to open Disk Utility and fully erase your drive before you reinstall. That should fix the problem. If it does NOT fix the problem, then the problem will have to be on Apple's end.

0

This is a duplicate of https://apple.stackexchange.com/a/380264/170023, but considering the solution is much, much less evasive than some of these, it’s important to pass along here.

A corrupt Keychain can prevent multiple services from logging in, including iCloud. Here is a way to figure out if your Keychain is the cause of not being able to login to iCloud.

  1. Open your Console app (under Utilities)
  2. In the Search field, type "Login"
  3. Press the Clear button.
  4. Try to login to your iCloud.
  5. Note the error messages. They may look something like this"

Error Domain=com.apple.accounts Code=13 UserInfo={NSLocalizedDescription=, NSUnderlyingError=0x7f*******c10 {Error Domain=com.apple.accounts.keychain Code=-25295}}}}

Break down the error codes:

Error Domain=com.apple.accounts Code=13

This code can be linked to Keychain errors with a simple Google search

Error Domain=com.apple.accounts.keychain Code=-25295

This error code (and many others) can be interpreted at this link:

           https://krypted.com/lists/comprehensive-list-of-mac-os-x-error-codes/

In this case, 25295 is interpreted by pressing Command F and searcing "25295". The search locates the following code:

Keychain Manager error codes

errKCInvalidKeychain = -25295

All indications are that the Keychain is corrupt, blocking services from logging in. In fact, by searching your own Apple ID in the keychain to locate login keys, you might try deleting Public keys. In doing so, macOS will fail to delete any key that is corrupt.

SOLUTION:

The solution is at this link: How to back up your iCloud Keychain

https://eclecticlight.co/2019/09/05/how-to-back-up-your-icloud-keychain/

If you backup your macOS device, your Keychain is also backed up. The article describes how to ensure your iCloud keychain items are also included in any local backup, and in doing so, it also describes how to restore your Keychain. Your Keychain is located in a file within your Library at ~/Library/Keychains. In finder, you need to select GO at the top menu (there's a way to unhide the "Go" tab... I don't remember offhand, but it is easy to find). Library is under the GO tab. This being said, this folder is also backed up to Time Machine or any duplicate of your MacOS device. Follow the instructions in the link to restore the ~/Library/Keychains folder to your MacOS device. I restarted my MacBook Pro, at this point, and for the first time in a couple of weeks, was able to login to all services. Problem solved!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .