2

Apologies if the etiquette of posting is incorrect, I'm brand new to the site despite lurking for years and couldn't seem to comment on the guide I mention below.

I've been trying to set up Win10 on my Early 2011 MBP, using various methods and receiving even more error messages/setbacks.

As an intro to the problem, I'm trying to use a method that doesn't involve using my internal Superdrive as I've discovered it's seemingly broken over the years and so it's unusable. Now this causes me Legacy/EFI problems I'm learning, to install via USB that is, even after fixing my MBR/GPT partition tables Windows will cancel after the install. I've tried to bypass by following this guide: No bootable device USB 2.0 MacBook Pro mid 2014

I've tried the above guide multiple times and have come across varying factors in the guide.

The most common one I'm facing (and my current problem), is when it comes to listing the volumes in diskpart - the FAT32 32GB partition titled BOOTCAMP I've set aside for Windows isn't listed in the volumes. This isn't always the case, sometimes it's shown - sometimes it isn't.

The only variable I can think of as to why it now won't show is because I've switched Windows 10 ISOs.

The reason I did this is because yesterday the install process probably went the furthest it did. All the files managed to xcopy to the virtual drive, then back onto the C drive - and even showed in the Mac boot screen (which occasionally doesn't happen) - but upon loading the screen instantly went blue and said there was a problem with my boot files and Windows needed to repair.

So I downloaded the newest .ISO from Microsoft yesterday. But now, as a result, the BOOTCAMP partition I've set aside never seems to show up in diskpart.

This has probably been the bane of my existence for the past 2-3 days - so any help is massively appreciated. Thanks.

  • What does VirtualBox have to do with Bootcamp? Do you want to install Win10 as a virtual machine (actually, your only option) or are you trying to install via Bootcamp (it's not supported, you may want to install Win7)? Please clarify which install you are going for. – Allan Jun 23 '17 at 11:27
  • If you see the attached guide: apple.stackexchange.com/questions/225387/… the guide uses VirtualBox as a substitute for Bootcamp to install a Windows partition - or is this likely the reason I'm running into issues, because I'm using W10 rather than W7? Other posts on here led to believe a W10 installation was still possible. – Max Clemens Jun 23 '17 at 11:33
  • See my link...The latest Bootcamp which is required for Win10 is for MBPs 2012 and newer. I have only seen Bootcamp installs of Win10 on unsupported hardware when they upgraded (not clean install) of a Win 7/8/8.1 install already in place. – Allan Jun 23 '17 at 11:34
  • Yup! I know my model is unsupported - it's still possible to install W10 on an MBP 2011 however. I think the reason Apple don't support is because of no sound drivers for the 2011 MBP. Typically the best method is to run the Legacy/BIOS mode which I can't do as my Superdrive is broken. Installing via Virtualbox points to your actual partition. So the installer runs emulating the ISO as a CD, and therefore uses BIOS mode (rather than the EFI mode from installing on a USB - only supported on newer MBs) and puts files on the actual Bootcamp partition for you to install from, not a virtual disk. – Max Clemens Jun 23 '17 at 11:40
-1

Just format the Bootcamp drive as "mac journaled extended" and then start the Windows installing process When the "select volume" window appears, delete the Bootcamp volume and create it again. Done.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .