8

My new iMac (2017, running 10.12.5) has by default F14/F15 bound to control the display brightness. I can't find any way to disable them, which means that binding them to other functions doesn't work. Using a third party tool like Keyboard Maestro can map the keys, but doesn't override the brightness adjustment, so you get two functions at once.

In my research it seems that some versions of Mac OS had a Display option under Keyboard Shortcuts that had the applicable options: Keyboard Shortcuts Preferences

Unfortunately I don't have that.

So my question is: How do I get that Display section back, or how do I unbind the decrease/increase display brightness shortcuts?

6

The Display section in Keyboard Shortcuts shows up when a third-party (non-Apple) keyboard is attached (I used a USB one, I don't have a wireless one to test). From there I was able to disable the shortcut keys.

Once I was able to disable them, I did some digging to find where the preferences are stored behind the scenes. Turns out that they live in ~Library/Preferences/com.apple.symbolichotkeys.plist.

Setting the enabled property to false for keys 53 through 56 of the AppleSymbolicHotKeys dictionary, will disable the F14/F15 brightness adjustments (this doesn't affect the F1/F2 keys on Apple keyboards).

/usr/libexec/PlistBuddy -c "Set :AppleSymbolicHotKeys:53:enabled false" ~/Library/Preferences/com.apple.symbolichotkeys.plist
/usr/libexec/PlistBuddy -c "Set :AppleSymbolicHotKeys:54:enabled false" ~/Library/Preferences/com.apple.symbolichotkeys.plist
/usr/libexec/PlistBuddy -c "Set :AppleSymbolicHotKeys:55:enabled false" ~/Library/Preferences/com.apple.symbolichotkeys.plist
/usr/libexec/PlistBuddy -c "Set :AppleSymbolicHotKeys:56:enabled false" ~/Library/Preferences/com.apple.symbolichotkeys.plist

The change will take place after a logout or restart. If you want to re-enable them, change false to true.

  • I'm using a USB wired Apple extended keyboard and have the display section – user1533191 Jan 2 at 17:44
3

robmathers answer is correct in spirit, but didn't work for me on Retina iMac 27" (2017) with full-size Apple Magic Keyboard 2 on macOS Sierra 10.12.6. The plist keys in the com.apple.symbolichotkeys.plist were different. Here are the commands that worked for me:

/usr/libexec/PlistBuddy -c "Set :AppleSymbolicHotKeys:7:enabled false" ~/Library/Preferences/com.apple.symbolichotkeys.plist
/usr/libexec/PlistBuddy -c "Set :AppleSymbolicHotKeys:12:enabled false" ~/Library/Preferences/com.apple.symbolichotkeys.plist

Don't forget to restart the computer (simply logging out doesn't work). After this is done you'll be free to map these keys.

  • Out of curiosity, what keyboard layout are you using? – robmathers Sep 1 '17 at 17:16
  • Default U.S. layout. – Dima Sabanin Sep 6 '17 at 16:08
  • how did you find out which AppleSymbolicHotKeys id maps to which F key? – Buju Feb 21 '18 at 17:27
  • I think I used something like this: softwares.bajram.com/softwares/#Full_Key_Codes – Dima Sabanin Feb 22 '18 at 18:03
  • This also resolved the issue when using a Magic Keyboard 2 with a late-2016 TouchBar MacBook Pro. So it must be that different KeyCodes are applicable depending on the keyboard type you're using. Entries 7 and 12 work for the Magic Keyboard 2, but with robmathers' answer, different entries (53 thru 56) may correspond to non-Apple keyboards. – stef Nov 1 '18 at 19:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .